Announcement

Collapse
No announcement yet.

Procedure result doesn't appear in email alert

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Procedure result doesn't appear in email alert

    Hello
    i try to execute many times some script monitoring (for example Get top 10 disk consuming files) but the email i receive report me only that "On the following devices Get top 10 disk consuming files procedure is runned and successfully completed." but without the output of the script that it's the most interesting thing.
    I need to search it into Script log of the device where the script was excecuted.
    It's the nornal behaviour of RMM?
    Thanks

  • #2
    It is pretty normal for most scripts/procedures unfortunately, and this would be a good feature request to have an option for all procedures. Somewhat ironically, this feature exists already for some procedures..sort of. For example, update/patch procedures have this option as in the attached pic: (tho I've personally had inconsistent results in this working)
    Capture.PNG

    However, custom, imported and most others do not have this option. I've also noticed that custom monitor procedures/scripts can also include the output within the alert email. Most of the default monitors don't but when I use a custom script in my monitor, the output does seem to be included in the email....sometimes.

    All said, this is something that is an annoyance, especially with how inconsistent it is. I've been designing most of my custom procedures to email me the results from within the script itself, but this is naturally not ideal. Going to the script logs per device in the portal, while nice to have there, is not efficient in my opinion. Including the log/output of any procedure/script I believe should be an option for any and all procedures and monitors.

    Hopefully iTarian can comment further.

    Comment

    Working...
    X