No announcement yet.

Bug Reports - Issues for Comodo Service Desk

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Reports - Issues for Comodo Service Desk

    Hi all,

    Lets use this sticky topic to report bugs and issues. When you are reporting it please provide as much as information as you can to be able to pinpoint the problem and quicker resolution.

    Here is a general format to report the bug:

    A. The bug/issue

    1. What you did:
    2. What actually happened or you actually saw:
    3. What you expected to happen or see:
    4. Whether you can make the problem happen again, and if so exact steps to make it happen:
    5. Any other information (eg your guess regarding the cause, with reasons):

    B. Files appended. (Please zip unless screenshots)

    1. Screenshots of UI bugs:
    2. Screenshot of setting page. Can be used instead of typed product and database version.

    C. Your set-up - Please provide these when asked specifically as a Private Message to Comodo Staff.

    1. What is your Company Name?
    2. What is your email?
    3. If it is related with Endpoints, Device OS details:
    4. Time Stamp of the problem

  • #2
    I get this error trying to open the service desk.

    Fatal error: Uncaught exception 'Exception' with message 'Unable to select the database msp_554a99e4d40fd38973c9e531' in /home/servicedesk/www/site/pim/pim.abstract.php:44 Stack trace: #0 /home/servicedesk/www/site/scp/ PimOperationsAbstract::switchToMspDb('554a99e4d40f d38...') #1 /home/servicedesk/www/site/scp/tickets.php(17): require('/home/servicede...') #2 /home/servicedesk/www/site/scp/index.php(17): require('/home/servicede...') #3 {main} thrown in /home/servicedesk/www/site/pim/pim.abstract.php on line 44
    Last edited by BegumB; 01-03-2019, 06:15 AM.


    • #3
      I get a similar error.

      Fatal error: Uncaught exception 'Exception' with message 'Unable to select the database msp_554abfebd40fd38973c9e557' in /home/servicedesk/www/site/pim/pim.abstract.php:44 Stack trace: #0 /home/servicedesk/www/site/scp/ PimOperationsAbstract::switchToMspDb('554abfebd40f d38...') #1 /home/servicedesk/www/site/scp/tickets.php(17): require('/home/servicede...') #2 /home/servicedesk/www/site/scp/index.php(17): require('/home/servicede...') #3 {main} thrown in/home/servicedesk/www/site/pim/pim.abstract.php on line 44


      • #4

        it should be fine now. Could you please try again?


        • #5
          Trying to add a test ticket but I get a warning about an "invalid due date".
          Mikael Berglund, 76BITS


          • #6
            Does it give the same error on all due dates? or specific one?


            • #7
              I tried a few different dates and got the same error.
              Mikael Berglund, 76BITS


              • #8
                Please try once more when you set your timezone same with your account from menu ->

                If this doesn't fix it, I will create a ticket for this to be escalated.


                • #9
                  In System Settings and Preferences I had set the dates to English UK format Day/Month/Year. By setting it back to US style it works.
                  Using UK style dates will be required for me to use the Service Desk otherwise it will be confusing to use.
                  Mikael Berglund, 76BITS


                  • #10
                    Originally posted by mhberglund View Post
                    Trying to add a test ticket but I get a warning about an "invalid due date".
                    I get the same issue. If I enter the date as d/m/y then I get the invalid date. If I enter it as m/d/y then it works ok. My settings are for d/m/Y as I'm in Australia


                    • #11
                      I see. We will investigate this and fix the issues.


                      • #12
                        The date issue when entering a ticket (that I mentioned above) seems to be fixed now. But now once the ticket is created, the due date is listed in the wrong format (ie m/d/y and not d/m/y) on the open ticket.


                        • #13
                          might that be related with the format chosen for your service desk? It is configurable under settings.


                          • #14
                            When editing a service desk user, you have the option to "add orginization". Within this window you can either search for existing or click the "Add Organization" button. This button does nothing when clicked. I want to assign this user to an organization that is not in the service desk list, but do not need to add them to my global organization listing as they are not a managed client that I will be using the RMM or Patch management software with.


                            • #15

                              You can only add Companies from the Comodo One portal (the main one). Once the company is added there, you can see see it in the other modules and use it.

                              The function that you are trying to access cannot be used for the moment.