after update comodo remote control trouble connecting to devices

Comodo Remote Control and ITSM portal issues.
Tried connecting to device that shows offline when it’s actually online. Eventually the status updates and allows me to connect.
Tried connecting to several devices already with same issue, shows offline while device is in use and user can even submit support tickets.

Hi @greenshieldtech,

We assume that the CRC had been logged out completely after use before the Update. Have you tried using another machine if the issue would replicate? You might want to as get the updated CRC version Remote Control 6.20.13250.18070. Please give us your feedback after your tests.

Running version 6.20.13250.18070, logged out and exited app then logged back in and still experienced this issue. So far that I can tell it’s happening to 2 devices I’ve tried. Other devices are working fine.

I’m currently using the latest release of CRC without any issues on the EU platform.

It is most likely that there is something being ‘blocked’ on the client-side of the two devices that you have tested so far. We suggest that you consult the following help guide so you can check any client-server communication issues:
ITSM Services - IP Nos, Host Names and Port Details (EU Customer –

I’ve been experiencing the same thing. I’m running 6.20.13250.18070, but this has also been happening with 6.19, and I think possibly earlier than that.

Some endpoints are randomly showing as offline in CRC. It’s important to note that they show as online in ITSM, and their last activity is current up to the minute. Sometimes they show as online when CRC starts, but then show as offline a few minutes later. If I send a reboot command to the “offline” endpoint via ITSM, they will show as online in CRC after they restart.

There have been no changes to any firewall port setting etc.

This has become a major problem for me. Comodo Remote Control is one of my most important tools, and I frequently can’t use it.

@Kees ,

We understand the urgency of having this reported case resolved. We have created a support ticket for investigation. Please check your forum registered email for details we will need.

Further to my comment, I am using it with multiple clients without issues.

Out of the 70+ clients this is installed on I’m having this issue with about 5 or 6 devices. Important to note these devices have the same profile as 48 others which are working fine without issues. They are not running any other AV or firewall and vary in OS’s. Some are Windows 7 while others Windows 10. All devices also have the latest updates.

@greenshieldtech are they all on the same network and protected by the same router’s filtering policy? Also, the ones with problems what version of Comodo Client Communications (ITSM) is installed?

Hello @greenshieldtech,

We have created a support ticket for you to investigate the issue you have reported regarding with the remote control.

Please reply at your convenience. Thank you for your patience.

Has anyone got a solution?

I have exactly the same issue, starting today. Different customers, different networks, many devices. All devices show online both on ITSM and CRC, but one. This one is online only on ITSM, I CAN remote control it clicking from ITSM. But on CRC it shows offline (even after a successful remote control session), so I cannot start a remote control session form there. Other devices (same Win 10 S.O, same configuration, same network, same firewall and AV rules) show online.


Updating: accessed the problematic device calling the remote control from ITSM. Rebooted it from the remote session. After the reboot it showed online both on ITSM and CRM.

And also: when it was showing offline, it happened in all instances of CRC (other users, other networks).

@helviojr ,

We thank you for the update. We tried replicating your issue with the current CCC (Client Communication 6.23.18107.18100) and Remote Tool (6.23.18102.18100) updated on the endpoint and all worked fine showing correct statuses.