Love it but my report function is broken...

I would first like to start by saying thank you! I have been a custom computer builder and break/fix tech for some time. I have deep connections in the business world and they have been asking for me to start offering Managed Services. After the initial sticker shock of other companies I was pleased to find one that would let me use these features for free. Especially while I learned how to use the system and automate maintenance issues etc.

That said, I have been trying to run a series of reports using the report function but it will not progress past the “In Progress” stage. I have deleted all other reports that were in the system and tried again. I have tried logging out and back in and nothing I can do is solving this issue. A little help with this minor glitch would be awesome. I work with a lot of HIPAA compliant businesses and these reports are a vital part of my compliance efforts.

Thank you,

Rogue Techy

Hi @Roguetechy ,

We appreciate your good response about our ITarian portal. Regarding the issue that you are experiencing, we have sent an email to your forum registered email address to gather more information to help us resolve the issue.

I have responded. Thank you for the quick response.