Some blocked pages get SSL error

I have to the best of my knowledge installed the required certificates on the machines and some webpages that use ssl are blocked and show the pretty page provided by comodo to say this webpage has been blocked. However pages like which i have used the b/w list to block no matter what i do just end up on an error page, “your connection is not private” “net::err_cert_authority_invalid”.

This gets the job done, but it looks so tacky for my customers. This really shouldn’t be that complicated. I have tried redirecting to pages, using the default block page, and a custom block page. i have reached out to comodo dome support and gave them every detail they asked for and have only got a we will look into it.

Have any of you ran into this and found a solution?

Hello @drewwcomputers,

We appreciate for letting us know about this issue. We have one reported case with the SSL error and currently being worked by our development team. We would like to verify if the one that you’re having is the same. May I request for the ticket ID number that was created with regards the issue for me to check the information hence I tried searching for the ticket and I am not getting any related result with SSL error under your email address. Thank you


Thank You For the response

Hello @drewwcomputers,

You are welcome and we appreciate your response as well. Let me gather the details on the ticket number and compare if it to the reported issue with the Dome SSL. We will keep you updated on this matter via the ticket your this forum page. Thank you

Yep, it was me that reported it, i think someone has renewed the SSL on comodos end, as it expires 2020 the one you have installed will end 2018 so it don’t match.

Morning, Any update? i have a case open but nothing in a few days?

Hello @dittoit,

Good day, we have requested an update on this matter and we will post the progress/update on this forum page or to the related ticket created. Thank you.

Hi @drewwcomputers and @dittoit ,

We were advised that Shield’s SSL certificate was recently updated due to changes of policy that chrome expects. You will need to update your certificates in order to resolve these issues. The New Certificate can be found on Configure > Policy Settings > Block Pages. Please delete the old certificate first before installing the new one. Also, the ITSM script for installing Shields SSL was also updated to deliver the New Certificate. Please reply to our email if the fix helped resolve your issue. Thank you.

Is there a script which will remove the old script and deploy the new one?

it just adds the new one, the old one remails but it does fix the problem.

Well thats half the battle, would be good to get rid of that old cert if they arent using it any longer.