Acronis Backup Console - Devices never appear after installing agent


I’ve installed the agent on two different computers:

  • PC: Windows 10 Pro (b16299.125)
  • macOS 10.13.1

Install of agent works fine, I can login, and I’ve tested / confirmed connections to management server and backup storage server.

However, the devices never appear in my management console.
I’m also unable to “apply default backup”, I click it, it spins, then returns to showing “Backup plan is not applied”

This is after multiple days and restarts of both PC and Mac, as well as trying to disable and restart the individual services themselves.
I’ve tried reinstalling the agent on both devices multiple times, but they never populate into my console.

The “customer” account for which I “logged into” on the agent is as follows:
Primary Acronis Partner Account (C1 account) > Client (company) > Customer (named person)

And then when viewing the management console for this “Customer (named person)”, there are no devices shown.

However, I’m able to install Acronis Backup on my Android device, login and initiate backup.
My phone also shows up just fine in the management console.

Also, some additional details from my windows agent logs and system:

%ProgramData%\Acronis\BackupAndRecovery\MMS\zmq_cl ient_sessions.0.log

2018-01-02 19:51:12:861 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: Ping
2018-01-02 19:51:12:955 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: ProcessConnection message=[‘Session’][’’][‘Pong’]
2018-01-02 19:52:12:860 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: Ping
2018-01-02 19:52:13:060 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: ProcessConnection message=[‘Session’][’’][‘Pong’]
2018-01-02 19:53:12:863 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: Ping
2018-01-02 19:53:12:956 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: ProcessConnection message=[‘Session’][’’][‘Pong’]
2018-01-02 19:54:12:876 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: Ping
2018-01-02 19:54:12:980 1520 D00000000: [01B35BBF-16BE-420B-AF7A-75BF0E9B28E5/E7A6609E-9C3E-4717-89DA-84487DB84D08]: ProcessConnection message=[‘Session’][’’][‘Pong’]


<message pid=“6412” time=“2018-01-02T19:35:39.413-08:00” level=“2”><![CDATA[
Event: Operation completed successfully.
| trace level: information
| OperationTiltle: EnsureUserProfile
| OperationID: 0x1
| CallingCode: 0x334686c826216630
| CallingModule: ipc_server.dll
| CallingExecutable: mms.exe
| ProcessUserName: MY-DEVICE\Acronis Agent User
| ProcessUserSID: S-1-5-21-2986989805-864566389-4151248892-1010
| ProfileID: 41661C13-B6CF-EF43-EDC5-0BF0A0314E9E
| UserName: MY-DEVICE\username
| UserSID: S-1-5-21-2986989805-864566389-4151248892-1001

PowerShell Command:
acropsh -m dmldump --service mms --viewspec-string Msp::Agent::Dto::Configuration

Connecting locally to mms …
Connected to mms (version: 12.0.4500.0) as MY-DEVICE\static
<report id=‘4AE28B3C-29F8-DBFE-1396-7C8522593186’ action=‘1’>
(’.AgentID’, ‘string’, ‘01B35BBF-16BE-420B-AF7A-75BF0E9B28E5’),
(’.AgentSecret’, ‘string’, ‘MYAGENTSECRETSTRING’),

(’.Authentication.UserName’, ‘string’, ‘’),

(’.Id’, ‘guid’, ‘15C60076-9C48-0914-B40B-9A003DD7DA93’),
(’.Id^PrimaryKey’, ‘nil’, None),
(’.Listening.Address.Address’, ‘string’, ‘’),
(’.Listening.Address.Address^Nil’, ‘nil’, None),
(’.Listening.Address.Alternatives’, ‘array’, []),
(’.Listening.Address.Alternatives^Nil’, ‘nil’, None),
(’.Listening.Address.Port’, ‘dword’, 0),
(’.Listening.Address.Port^Nil’, ‘nil’, None),
(’.Listening.Address^Is’, ‘string’, ‘Msp::Agent::Dto::ServerAddress’),
(’.Listening.Address^Nil’, ‘nil’, None),
(’.Listening.SessionType’, ‘string’, ‘’),
(’.Listening.SessionType^Nil’, ‘nil’, None),
(’.Listening.WorkersCount’, ‘dword’, 0),
(’.Listening.WorkersCount^Nil’, ‘nil’, None),
(’.Listening^Is’, ‘string’, ‘Msp::Agent::Dto::ListenInfo’),
(’.Listening^Nil’, ‘nil’, None),
(’.PortalAddress.Address’, ‘string’, ‘’),
(’.PortalAddress.Alternatives’, ‘array’, []),
(’.PortalAddress.Alternatives^Nil’, ‘nil’, None),
(’.PortalAddress.Port’, ‘dword’, 443),
(’.PortalAddress^Is’, ‘string’, ‘Msp::Agent::Dto::ServerAddress’),
(’.RegistrationServer.Address’, ‘string’, ‘’),
(’.RegistrationServer.Alternatives’, ‘array’, []),
(’.RegistrationServer.Alternatives^Nil’, ‘nil’, None),
(’.RegistrationServer.Port’, ‘dword’, 443),
(’.RegistrationServer^Is’, ‘string’, ‘Msp::Agent::Dto::ServerAddress’),
(’.Timestamp’, ‘string’, ‘1/3/2018 3:18:25 AM’),
(’.Uplink.Address.Address’, ‘string’, ‘’),
(’.Uplink.Address.Alternatives’, ‘array’, []),
(’.Uplink.Address.Alternatives^Nil’, ‘nil’, None),
(’.Uplink.Address.Port’, ‘dword’, 7794),
(’.Uplink.Address^Is’, ‘string’, ‘Msp::Agent::Dto::ServerAddress’),
(’.Uplink.IsSuspended’, ‘bool’, 0),
(’.Uplink.SessionType’, ‘string’, ‘ams’),
(’.Uplink.ZmqPublicKey’, ‘string’, ‘MYPUBLICKEY’),
(’.Uplink^Is’, ‘string’, ‘Msp::Agent::Dto::UplinkInfo’),
(’.Zmq.ZmqPrivateKey’, ‘string’, ‘MYPRIVATEKEY’),
(’.Zmq.ZmqPublicKey’, ‘string’, ‘MYPUBLICKEY’),
(’.Zmq^Is’, ‘string’, ‘Msp::Agent::Dto::ZmqConfig’),
(’^Is’, ‘string’, ‘Configuration::Option’),
(’^Is’, ‘string’, ‘CopyableToMedia’),
(’^Is’, ‘string’, ‘Msp::Agent::Dto::Configuration’),

<dml-report-completion action=‘1’/>

<successfull-completion action=‘1’/>

Using the Acronis Connection Verification Tool, I can check my connection / ports for all service:

PS> .\port_checker_en-US_x86.exe -u=‘EMAILUSERID’ -p=‘PASSWD’
Check for 443 Ok Ok Ok Ok Ok
Check for 7794 Ok Ok Ok Ok Ok
Check for 44445 Ok
999.999.999.999 Ok
Check for 8443 Ok Ok Ok Ok Ok

Hi Damon, thanks for the quick response, I really appreciate it!

Here is the result, it looks like it worked, but I still don’t see device in my management console:
PS C:\Program Files\BackupClient\BackupAndRecovery> .\register_msp_mms.exe register ‘EMAILUSERID’ ‘PASSWD’
check credentials: Root (Composite)
[Is (Common::String) = Msp::Agent::Dto::CheckCredentialsResponse]
IsValid (bool) = 1

set registration server address: Root (Composite)
[Is (Common::String) = Msp::Agent::Dto::ServerAddress]
Address (Common::String) =
Alternatives (Array)
[Nil (NIL)]
Port (unsigned long) = 443

set ob rpc address: Root (Composite)
[Is (Common::String) = Msp::MMS::Dto::SetRpcAddressResponse]
RpcAddress (Common::String) =

register mms: Root (Composite)
[Is (Common::String) = Msp::Agent::Dto::RegisterAgentResponse]
AgentID (Common::String) = 01B35BBF-16BE-420B-AF7A-75BF0E9B28E5
Uplink (Composite)
[Is (Common::String) = Msp::Agent::Dto::UplinkInfo]
Address (Composite)
[Is (Common::String) = Msp::Agent::Dto::ServerAddress]
Address (Common::String) =
Alternatives (Array)
[Nil (NIL)]
Port (unsigned long) = 7794
IsSuspended (bool) = 0
SessionType (Common::String) = ams
ZmqPublicKey (Common::String) = MYPUBLICKEY

From my (Android) mobile device, using the Acronis Backup app, under Access and Recovery, when loading I see the two categories “This device” and “Computer backups”.
However, once the app finishes loading both categories, only one device is found under “This device”, and it is my phone.
So no other devices are seen. I’ve followed up via email as well.

@RoninMedia ,

We have made a follow up in your case and our Acronis Team had sent correspondence via email for investigating the issue. Please check your mailbox at your convenient time. We will await your response as soon as possible.


I seem to be stuck in the same place. Is there a fix to getting my newly installed Device to appear?


Hello @jirehconsulting,

We love to investigate further on your reported concern. We created a support ticket to understand the issue further. Please feel free to respond to the support ticket. Thank you

It appears that I was too impatient. The morning finds the Device visible in the console.

Thank you.

@jirehconsulting ,

We’re glad to hear that the issue you have reported had been resolved.

We are actually having the same problem— today was the first day we installed, we’ll give it until tomorrow to see what happens too. . … .

@evoevoevo ,

We will create a support ticket for you to have your case identified and investigated as well. Please check your mailbox at your convenient time.

The machine actually did show up the day after - – is this supposed to be normal?

@evoevoevo ,

The devices should appear after installation. You can use this helpful guide to double check to make an assessment.