Agent unvailable

I have a previously working agent which is now is no longer working and I’m unable to determine the cause. I do not believe I performed any changes to the RMM console or the end point agent. I have attempted to reinstall the agent (due to laziness) and it has not corrected the agent communication. I have reviewed the logs and I’m unable to determine the cause. I updated the log level to 15 on the agent and below is some the logs I’m seeing. The patch management agent is working just fine. I have 4 other agents successfully working at the same location.

sample agent logs: (1.77 KB)

Oh I’ve tried the usual recycling of the service as well as I recycled the server for maintenance and still does no reconnect successfully

Hello @dagint ,

Thank you for the logs. We will analyze them and get back to you with feedback when we’ll have news on the issue.

When you install the RMM on a client computer, there are two files that are generated and saved in the same folder the installer file was when you ran it. If you delete those two files, the agent will not work properly. Try completely uninstalling the RMM and Patch Manager. Then reinstalling them both on the workstation. Move the installer file to a place where the files will not be deleted before running it and see if that solves your issue. When I run the file on a client computer I save it to the c drive directly before running it. That way people won’t attempt to delete those files.

I think the second install created a completely new device. It did not replace the original. I didn’t realize there was a new device as the old one still listed as Unavailable. I removed the old unavailable device manually. This was not expected behavior for me. I would have thought it would have replaced the existing device. Moving forward is this something that should be expected when reinstalling an agent?

Yes, you need to remove the device from the console manually and then when you reinstall the RMM it will add a new one.


Yes, as HuskyLogic mentioned, you will need to remove the device from the console as well, when you remove the agent from a machine.