An error occurred on last information update. Error code: 0x80070002

I have a number of machines (and a ticket raised with C1) that currently have no virus protection, and no simple way to resolve.

The error is ‘An error occurred on last information update. Error code: 0x80070002’ and when trying to start the CCS application, the user is prompted to run diagnostics, which subsequently fail.

I need a resolution to this ASAP, that preferably doesn’t involve me contacting dozens of people to tell them that their data is potentially at risk because the security software we suggested they use isn’t working…

any help is greatly appreciated.

@curatrix_pl ,

We have seen the raised concerns about failing update with the CCS. We will provide instructions on the email you have sent in order to resolve the issue as soon as possible.

Thanks Jimmy, appreciated.

Ok, so far, the suggestions offered by support have failed to fix the issue.

This needs to be resolved ASAP by Comodo. The number of times in the last few months that there have been ‘issues’ with CCS that has required intervention is unacceptable. I have never known Symantec, McAfee, Sophos, Avast, Kaspersky or any other AV product ‘fail’ to update correctly at the rate that CCS does, leaving the user so completely unprotected.

I want to continue supporting Comodo C1 through its development, but at this point, it is becoming brand damaging to us to deliver a solution that so frequently fails to deliver, and i am being forced to look at alternative solutions. .

Hi, same problem here. Some workstations in device list are with same error code: 0x80070002 (CCS communication problem)

Hi @curatrix_pl , @Aurius ,

We apologize for the inconvenience it caused. The reason why you are getting the error is because the client security path was changed.
The error code 0x80070002 on your portal means the system cannot find the file specified. This behavior was fixed in the current version so we expect that you will not
get this kind of error message again.

Please follow the instructions below and applied it on the affected PC.

  1. Go to CCS installation folder and rename it to the correct one.
    *remove old suffix
  2. Reboot the pc

After the reboot of your endpoint, you will able to update the client security from the portal to the latest version.

removing the suffix did not work. Neither did trying to uninstall using the script provided. The one machine that i was working on is now configured with Avast until i can get physical access to the machine to further work on it. I dare not try the other machines yet, but suppose i will have to…

Hi @curatrix_pl
To mirror a reply made on another thread you commented:

Here is the (official MS) link of the Microsoft fixit for problems that block programs from being installed on to/removed from the system.

thanks, that found a ‘dead’ entry for CCS and removed it. Still unable to install, error / status returned by MSIEXEC is 1603.

Hi @curatrix_pl
For the error 1603, can you please do try the suggested actions in the following link: error 1603 suggested solutions

I have verified that those solutions are not related to this issue.

Running the CIS_x64.msi with verbose logging on, it indicates that the error is related to the custom action ‘SearchForRelatedProducts’.

Hi @curatrix_pl
With the support ticket already closed, we would like to get another crack on a similar issue if time and if all parties will permit. Please don’t hesitate to contact us again ( if you have another endpoint affected similarly so we can get to the bottom of it and prevent any similar incident with future updates of the Comodo Client Security (CCS).

Thanks for solution, this guide helped, now all endpoints works.

Hi @Aurius ,

It’s good to learn that the resolution we sent worked. If you have other issues or questions please do not hesitate to reach us through Thank you.