Cannot install agent

i have tried to install the patch management agent for multiple systems but it just doesn’t work. i used the custom msi installation module in itsm, put in the url and command line script. but when i later check, i see installation failed. then i tried to install for only one system. i downloaded the application agent, ran the command line and got ‘access denied’. i don’t know how to go about this again. i want to be able to deploy it to multiple systems silently at the same time.


When you run a procedure you have the option to select the user that will run it on the endpoint. As options there is a system user and logged in user(s). Please let us know if this was under the system user, if the user you have started the procedure had administrative privileges.
In addition, if possible please provide us with the procedure you have used.

Looking forward to your reply.

hello wyatt. i did not run any procedure. i used the option"install custom msi" in the itsm. i did not see any option for selecting system user or logged in user. better still you could give me steps on how to deploy the agent to multiple systems. every step i have followed doesn’t work. i have even tried to install locally using command prompt in elevated mode. i get the “access denied” response.

This is what i get when i try to install on only one system. in the attachment below, i see access denied. if i try bulk installation via itsm, using the “install custom msi” option, i check the logs and i see message that says could not install patch management msi.

Hello @chales ,

We have contacted you over email regarding the issue reported above.

my email is…not

Hello @chales ,

We have used the correct email, however in the reply here we used your Forum User Name, real email address should not be disclosed on a forum post.

hello dylan…i have successfully installed it on one endpoint. but the issue now is i can’t see the end point in the patch management console.i have restarted the system but still can’t see it. i checked the PMlog and it says at the end …successfully installed. but i can’t see my computer in the console

hello @Dylan i’m still waiting for your response on this…it is very critical please.

Hello @chales I am having your same issue. I hope a fix is found soon.

On the device that is not connecting please check if communication to our server is possible


IP: (the IP might change, ALWAYS ping before)
Used port: 443 TCP Outgoing

I have verified that it can reach also ITSM see these servers but not patch management.

Why cannot patch management and RMM both be deployed with the ITSM agent all at the same time? Also, the “side load” msi link is broken so I can’t find that or otherwise I would put it in a GPO.

The PM agent should be part of the RMM deployment when issued from the ITSM module, this is needed because If your want to deploy PM by itself it is requesting for the RMM ID.

Support, When is the PM functionality migrated to ITSM, I think there should be just one Module and the rest (RMM, PM, Serv Desk and others) be just functionalities of the ITSM.

I created a bulk installation package from ITSM - patch is included then? Great. Shouldn’t agents show up under the patch management screen then if they have the RMM already installed and already show up under devices?

Then I am confused. I have installed ITSM clients. Do I need to install the patch management agent or not?

I do not see any such page. I do however see Licensed Applications, Patch Management, and then there’s Agents. I only have one device showing up there and that’s because I manually installed patch agent on that one device- and it’s in the wrong company also.

got it