Cannot log in to Comodo Remote Control

Hi - brand new to Comodo here.

I tried downloading “Comodo Remote Control” and ran it on a workstation. It opens up a window (screenshot below) - asking for email address and password. I put in my Comodo credentials, but then it displayed the message shown at the bottom of said window - “There is no user with this domain\login in the system. Please try again.”

What am I doing wrong here? From the guide here Remote Management Of Windows And Mac OS Devices, Remote Monitoring And Management, Endpoint Manager it seems to be suggesting that domain verbiage relates to if you logged in via the ITSM option, but I made sure I have the Comodo One tab selected and the fields were clearly labeled “email” and password (if you tab over to ITSM it does ask for domain, etc.)

Any assistance would be greatly appreciated!

@mizugori you are logging into the USA servers for CRC, is your Comodo ONE account on the USA platform?

@nct that is a good question, I am based in the USA so I assumed - how can I check and/or if it’s set to Europe change it to USA?

As @nct mentioned, your C1 account is most likely not hosted in the USA server, @mizugori.

The two regions shown in the CRC window refers to where your C1 account is currently being hosted. One way to determine on which region your C1 account is being hosted is to check the URL of the C1 portal. If you log in to the C1 portal using “”, then it is in Europe. If it is “”, then it is in USA.

@Rick_C Thank you - yes it is so I guess Europe. Does this matter, and can/should I change it? (I mean for the purpose of logging in I will try selecting Europe now in the drop down. But long term, does it make sense for my account to be hosted in Europe? Will it affect performance of some modules/applications or cause other issues?)

If I should start a new thread let me know, but I didn’t want to create clutter. I just enrolled a device. Now when I open remote control on my workstation, and log in (now selecting Europe in the drop down as discussed above) I get in successfully and I can see the device I just enrolled. However I can’t figure out any possible way to initiate a remote session.

I went into the web portal ( and I can see if I select that device in my device list, and hover over remote control, it says I cannot because the device’s version of ITSM agent needs to be updated. (This is odd because as stated, I just enrolled it less than 10 minutes ago but okay, maybe the enrollment link hasn’t been updated to the newest version.) How do I upgrade said agent?

The region hosting mainly affects your connection to the C1 portal, @mizugori. If you are having outright issues accessing the C1 portal from where you are located, please test first if there is an issue with your internet connection (ISP-wise, traceroute check, etc.). If you find none, then most likely signing up for the other server region will help.

If I should start a new thread let me know, but I didn’t want to create clutter. I just enrolled a device…

You can try refreshing the ITSM Device List page (logging out/in back, etc.) and check if it will state the same ‘needs to be updated’ message.

You can also choose the device and click on the ‘Install or Update Packages’ action. Then choose ‘Update Additional Comodo Packages’. If you are unable to choose the ‘Update Comodo Client - Communication’, then that means the endpoint already has the latest CCC version. If you can click the box, then go ahead and update it.

I have same error There is no user with this email/login in the system. Please try again
Europe/USA error is the same.
This account is Enterprise.
I have another account MSP and is working, then the problem is not from computer.

@artware ,

We will create a support ticket to investigate on your reported issue. We will contact you via your forum registered email for correspondence.