Cannot Login to

Why do you guys have so much difficulty with Captchas? I cannot login. It keeps telling me to do a captcha, I do it (CORRECTLY) and it just loops back around says “Invalid” and then i do it over again, and its over and over.

What do I have to do to fix this?

Hello @cengle

We have created a support ticket in regards to your report and will reach you via your forum registered email for further correspondence.

I am also having the same issue since Monday, 7/27/20. I have cleared cache, tried incognito in Chrome, Edge and Firefox. Also tried logging in on a system that I have never used connected via hotspot and still received the same CAPTCHA loop.

looks like it was an expired password. Support directed me to to login and then i was prompted that my password had expired. After updating it there, I was able to login at

Hi @droberson2,

Thanks for letting us know that issue is fixed.
Please reach us anytime if you have an issue, we are happy to help you.

Kind Regards,