Can't log in to Portal (AGAIN)

Portal is not allowing logins again. When trying to do a password reset it also says “User not found”. Very frustrating that this is happening again.

Support has been notified of the issue but no response. Is anyone out there?

This is absolutely horrible that I have to post here to figure out what is going on with my account. The below has been discussed via email and no response for almost 8 hours

Wed, Jan 15, 2020 at 11:56 AM Alex Occhiogrosso <> wrote:
		Hi Terry,

		Thank you for joining Itarian, I will be your account manager moving forward. If you have any questions in regards to licensing or security I would be happy to help.

		Let me know how I can be of assistance to you.


Alex Occhiogrosso
Partner Success Manager
201-620-6924 | Direct
908-655-8982 | Mobile

Wed, Jan 15, 2020 at 12:16 PM Terry Rigby, <> wrote:
		Hi Alex,

		 I actually already have a MSP account, however this morning when trying to log I to the portal I was unable to log in and when I tried to reset my password I was shown the message that the user does not exist.  Can you help?

Wed, Jan 15, 2020 at 1:31 PM Alex Occhiogrosso <> wrote:
		Hi Support,

		Terry is locked out of his itarian account can we please create a ticket to help him get back in?

		Thank you.
Wed, Jan 15, 2020 at 1:34 PM Terry Rigby, <> wrote:
		Thanks Alex and Support,

		  I look like a bit of an idiot this morning due to this issue as I am trying to onboard a new client and Itarian is not working.

Wed, Jan 15, 2020, 3:11 PM Joseph Jaghab, <> wrote:
		Hi Terry,

		How can I help you? Do you have any specific questions or would you like to
		schedule a call?

		Thank you

		Joe Jaghab
		Partner Success Manager</td>
Wed, Jan 15, 2020, 3:18 PM Terry Rigby, <> wrote:
		I can not log in to the msp portal and when I try to do a password reset it tells me the username or email is incorrect</td>
Wed, Jan 15, 2020, 8:14 PM Hi,
		  Has anyone been able to look into why I can no longer log into my account? The email associated with the account is <a href = "mailto:"></a>


It shows in the forwarded email from Alex to support what the problem was. Why the hell are they asking me a second time what the problem is? Can’t support take two seconds to read an email? Is this the quality of support we can expect for a paid product?

I finally got a hold of Tommy via the support email (I emailed support directly instead of replying to Joseph’s email to me).

He helped with the problem like a boss and all is well again


Hello @terry.r ,

We are sorry for the inconvenience. Our technician Tommy found that you have been trying to login to Europe instance instead of US instance and experienced this issue. Thank you letting us know that your issue has been resolved now.

Thanks @SethHD ,

Yes Tommy got me all sorted out but I don’t think it was just a US/EU issue. What I am wondering is what changed on the Itarian website? I used to be able to go to and click login and it would take me to the correct geographical region and I could log in. I’ll take the responsibility of not noticing this though.

Even after Tommy directed me to the US site I still had to do a password reset to be able to get in so something other than US vs EU was at play here. Also, every single one of my scheduled procedures failed yesterday evening when I was still locked out so it seems like this was more than just a US vs. EU portal thing.

Not to mention, I was also locked out of the Itarian Remote Control app and I was definitely choosing USA there and not EU.


Low and behold I can once again log in just fine at (using an private browsing window on a pc I have never connected to itarian with before to avoid any previous caching and cookies)

This seems more like a geo based redirection issue on Yes, I was hitting the wrong location previously, but that was because was most likely due to sending my credentials to the wrong server. As I stated before, more going on that just me hitting the wrong server. loggin in via used to work, then it broke, now it works again…