Can't log in

I am also unable to log in. After entering my credentials, ‘Please verify CAPTCHA.’ appears above the username and a captcha box appears above the sign in. Verifying the captcha and attempting to log in causes ‘Invalid CAPTCHA value.’ To appear above the username. When attempting to reset my password, I get a ‘User is not found.’ error, though I’m fairly confident I’m using the right login. I’ve attempted both the Itarian and Comodo logins, same results on both.

Nevermind, was trying to sign in to, needed to sign in to Why isn’t there one international login database?

@tomPurd ,

There are 2 server instances. EU and US. You have accidentally tried signing in on the EU instance.

Same here… unable to login to eu login page… I get captch then back to login screen with error ‘ESOCKETTIMEDOUT’

I get the same error on the US login page.

US Login Server.

Attempted login via:
Android Itarian App

Also getting ESOCKETTIMEDOUT when trying to log in through the IOS Comodo One App.

@jrohrer @nunyabiznus, @Ed_Johnson

This is a server-side issue that our Backend Team is working on getting resolved as soon as possible.

This is happening to me too. Oddly, ONLY on the web console. The “Remote Control by Itarian” application logs in and will allow me to remote to client systems. But I can’t manage anything else at all since I can’t get into the web console.

Update: earlier was getting the “esocket timeout” message, now getting “Comodo Account Management did not respond in time. Please try again later. If this problem occurs again, then please contact support.”

@misolutions ,

We’ve faced a server-side issue with the logins awhile. Alls ervices should back in full operation now. Please check at your convenience and let us know

I can confirm… logon is now functioning correctly.

@Ed_Johnson ,

Thank you for giving us an update.