Can't log into portal (also)

Hello, I’ve tried different browsers and even elected to reset my password and I still cannot log into our company via:

It simply continues to go back to the login page instead of the 2FA page waiting for my google authenticator code.

Error: “invalid captcha value”

What is going on?!? I need access to our MSP tools and whater password I reset, didn’t work for anything but some other weird portal .

Seems to work now with the new password I set. Was there some type of “password expiration” that took place?

We cannot say for sure how you triggered such a situation, @ktaylor. But there are a few settings related with Password and Account policies that handles the lockout time, session timeout, and password expiration.

I recently logged out by accident, and tried to log back in, and keep getting the invalid captcha, also. Doh! n/m, I think it was defaulting to EU instead of US.

There were similar reports before of the same ‘invalid captcha’ when a user tries to log in to the portal. Clearing the browser cache helped with the situation.