CCS Firewall problem.. seems a regular theme.

OK… so I have quite a few devices running fine with CCS… but the ones I do have problems with (and it’s almost ALWAYS the firewall) are usually pretty much impossible to solve without a wipe and reinstall (This is not always possible in the real world).

So yesterday I had a system running 11.1 CCS… To my knowledge this device has not had 11.2 installed, although it could have as the rollback was a little chaotic at the time. Anyway CCS 11.1 was running fine on this device. Another company requested I disable the firewall as they were having problems with a network Printer/scanner. I was convinced the firewall wasnt the problem but did as they requested… Still problems… they were still blaming Comodo and had a very low opinion of it which was a bit embarrassing in front of my clients… anyway… to satisfy them I completely removed CCS with the local removal tool. Printer still wouldnt work… they still blamed Comodo… in the end they routed print/scan jobs via the server instead. I reinstalled CCS later that day via the ITarian platform… all seemed well… Then a dreaded red dot appeared in itarian… ‘The network firewall is not functioning properly!’.

As this company had already had a lot of problems due to the rollback on 11.2 on some of their devices I was hesitant to tell them they had yet another ccs problem. Later that evening once their office was empty, I remoted in and opened ccs… a big red warning ‘Firewall has a problem -select FIX’. I did this… It went to repair install and there were a couple of errors that the installer was attempting to replace files with older versions (maybe there were remnants of 11.2 afterall, but this endpoint had until today been running fine with 11.1). Repair failed. I initiated a remote removal of ccs via the Itarian procedure I always use… Success. To be sure, I remoted in and also ran the local removal tool also… success. Rebooted…

I initiated a remote install once more… exact same scenario… went through whole process of ‘full’ removal again. Created a bulk install file and installed locally… failed. rebooted… ccs was back and apparently working… 1min later… red dot… firewall error.

Repeat removal again and reinstall as Admin (could be permissions problem although user was member of administrators but clutching at straws now). Same problem… errors on install but worked after reboot but with firewall error.

Now I could leave the firewall disabled and use the windows firewall… but I’d prefer to have the software running properly and not have clients seeing a notice that parts of their security software are switched off… I’m used to using Eset and still have 85% of our clients with active subscriptions. For years security software has been install and pretty much forget for us other than general monitoring of updates/licences etc.

I like the integration of ccs with the itarian platform and the intention ‘was’ to migrate them over to ccs as they expired, but we are having so many problems with it at the moment that I’m starting to think the workload it generates isnt worth the convenience of being able to monitor it within the platform.

Anyway… after that moan… anyone else had this problem? able to shed any light on a fix? I’m pretty confident a full wipe will fix the problem but that’s simply not possible as the client is already a little wary of ccs and I dont want to lose them.

Hi @Ed_Johnson ,

We apologize for any inconvenience this has caused you. Our Support Team is working on it and they will reach out to you as soon as possible through email. Thank you so much for your patience.


Ed_Johnson, we are in the same situation where we fear that we may lose our biggest customers
It is frustrating and time-consuming to support customers with these issues as some machines are miles away

One of our customers is already suggesting that we migrate to something else because ever since we brought them to the new platform its been one problem after the other
Customers just have to stay in business and not worry about security that should be running silently in the background

The development team needs to refine their QA testing

Hello @Nevillo1, we sincerely regret to hear about the inconvenience that you and your clients have experienced. We take your feedback extremely seriously. We will let the Project Manager’s hear about these feedback.

Thank you for your support.

You are 100% right.

Itarian allows an ecosystem of third party products to be included in it…Comodo endpoint security is one of them…everyone involved in that product is aware of the issues and working hard. As Itarian we are working on expanding our ecosystem by adding other providers as well.

@Ed_Johnson same situation here… still waiting for Engineering to review this with on eof our endpoints but is been days now. Still an issue and have tried uninstalling via the UI Branding script and reinstalling with the new included UI Branding script which was not included in the first Ticket response in order to rectify this issue. @Ed_Johnson do you also have UI Branding on this Profile? I have tried removing the existing Profile and then reapplying after the uninstall and it worked on some endpoints but not all (Win7Pro64). This seems to be an issue with UI Branding and the roll back with using the wrong script to uninstall as the initial fix, UI Branding was not in the QC for this initial script as was explained in previous tickets. Some resolution to this soon would be appreciated as I find the platform moving in the right direction for us ITarians, without the big setbacks of course.

Hi, regarding the opening post, I have the same problems. I try to see the best in this product but there are many recurring issues like firewall and CCS issues. I don’t have much clients like some others here on the forum but the frequent uninstall/install ‘fix’ takes too much time.
Uninstalling, rebooting, hoping that the system can be reached. (I had a few systems yesterday that were starting in recovery mode after uninstallimg 11.2##)

And I’m convinced that this is a common problem for every MSP here.
I would like the ‘Project Management’ to review the install/uninstall procedure and some other basic functionality to be stable and logical. Not to introduce new functionality into every update and not tackle the old problems/issues.
So, I have, unfortunately, the same experience.

Yeah… luckily we only have about 30 of our clients devices with CCS installed… The system failure upon removing CCS is a serious flaw… so serious that we have decided to no longer use CCS on any more of our clients devices and have gone back to our usual security provider. It really is a shame as the integration within Itarian was ideal but there is no way we can risk installing a program that has the likelihood of blitzing the machine when you try to remove it. The uninstall utilities simply do not work some of the time. We dont rebrand CCS, it’s completely stock yet has still rendered a number of our clients systems unbootable necessitating a full wipe to repair after removing CCS…

At least the 11.2 debacle has highlighted the risk involved in putting CCS on (or rather attempting to remove it from) business critical devices.

Unfortunately we are now left with around 30 devices that we are reticent to attempt a removal of CCS… they will be gradually replaced as devices are upgraded rather that take the risk short term.

As I said… nothing against Comodo… Itarian is a great product… I dont know enough about the history of CCS to comment on previous versions but it appears that the current product has some serious flaws and its removal process needs a complete overhaul.

I was thinking too to move to another security system, but am hoping the software will benefit from all our input and evolve. Still very reluctant to introduce this product to new clients.
Even now I have still a lot of devices that I have to rollback manually after the 11.2 debacle.

So developers: Comodo One was promoting itself as a security platform for devices with CCS (AV and firewall). Please make these basic features rock solid and reliable before introducing all new features!

Hello @Ed_Johnson , @ailan ,

We really appreciate your feedback, rest assured that our Development team will hear about this.
For the removal tool of the css version which has issue, please see
latest CisCleanupTool which works correctly with CCS 11.2## and previous versions.

Password : c1234


Hi @Jay ,

thanks for the link.
As we’re now already ‘criticizing’ different aspects to sharpen these up, or give suggestions the following:
Can you post these clean ups on your own platform, on the ‘Tools’ page? For example on the ‘Comodo Cleaning Essentials’ ?
This looks a bit more professional than using a google drive link.
And this will keep all the releases on the same page.
The last comodo cleaning tool on your page is dated in 2017.
please use your own platform to keep all these scripts together.

Hello @ailan ,

Thanks for the suggestion, we will forward the request to our Product Management team and we`ll let you know
as soon as we have an information.



This issue seems to be resolved with the current release of the CCS Uninstaller. Make sure to download version for your architecture and run the app after each reboot until the Uninstaller has found no trace of CCS, then reinstall from EM. If using UI Branding remove the Profile and add it back after reinstall is successful.


I had also had the issue with the left over stuff for the firewall. In my case, it was the Comodo firewall driver in the NIC. What I done to fix it was remove the software, then went into the NIC properties, and uninstalled the Comodo Firewall driver from the system through the NIC properties. Then I ran CCleaner to look for left over registry keys, the I used autoruns to manually remove anything that was left over. This worked for me, so it might work for you too??

Uninstall and firewall has always been an issue for us.

The uninstall seems to be working now though which is great!

The current re-release of v11. 2 also has a working firewall, but I know how fragile that is. I still believe like the competition is doing, being in Windows firewall management and drop this.

I know there are technical reasons why they do not, as it allows for network protection in containment etc… But one thing that cannot fail is the firewall as this stops access and renders a device dead.

Hello everyone,

Thanks for the feedback,
It is glad to learn that the latest uninstaller work well on your end.