Communication client is not updating

client communication app is stuck on version 6.43.41148.21120 for almost all of the devices.
The few devices on later version were enrolled in later dates so the download link already included an updated version.

using the “update additional packages” doesn’t change the outcome.

I tried sending the script to restart comm client and then update it (as seen suggested in the forum here: no update of Windows Communication Client - Products / ITarian Endpoint Manager - ITarian Forum).

I ran the script of “uninstall and reinstall comm client” but it remained on the same old version and I needed to re enrol the endpoint.

I was migrated to xcitium, is the non automated updated of the comm client issue is somehow connected to this?
Is there a script to force update the comm client with same enrolment info?


Hi @InfoSecAdmin

Can you first please confirm / answer the following: -
Did you ask or request to be moved to Xcitium?
Do you see Xcitium or ITarian logo in the top left of your platform?

For your information ITarian currently is on Agent version 7.3.44979.22120

Regarding your 1st question - I don’t remember requesting nor asking but I might had done so (I don’t have a record of it).
It might have been a prompt.

I see my custom logo on the top left.
the url after loging in via changes to Xcitium Platform

Hi @InfoSecAdmin

It looks like the system you are using is Xcitium not ITarian.
Please reach out to them on and they should be able to help you.