Configure Email Outgoing settings

Anyone have success with configuring the outgoing email server. I keep getting the error 'Mail could not be sent to the admin user. Please check the admin emailid/server settings. I verified all server settings are correct. Any ideas?

Hello @jlbreaux

This feature helps you to configure Outgoing Server with SMTP (Simple Mail Transfer Protocol) settings of youremail server to manage sending out emails.
Follow few simple steps to configure your Outgoing Server

  • Click gear icon in the top right
  • Click CRM Settings
  • Click 'Other Settings' drop-down in the left
  • Click Outgoing Server. You can click on pin icon next to it to add a shortcut to your settings home page
  • You can view default settings provided by CRM. To modify, click Edit button in the top right
a Server Name Provide where is the actual domain name. For instance, gmail accepts ssl://
b User Name Provide your user name.
c Password Provide your password
d From Email Emails will be sent from the email id you would specify in this field; else, emails will be sent via the email id of the current user
e Requires Authentication Click on the check-box to enable authentication before sending an email.
6. After configuring details, click Save Heads up!
  • By default, the outgoing server is configured with CRM settings. You can manage sending out emails with these settings. However, we will recommend you to configure Outgoing Server with your own SMTP settings.
  • If you prefer to retain CRM server as the outgoing server, we recommend you to configure your domain's SPF record to include the CRM server as a valid sender for your domain.
  • You can click on Reset to Default in edit view to populate default set of values provided by CRM
In order to access the guides and documentation for the CRM module, please log in to your Comodo One account, open the CRM module and click on the "i" - information button on the upper right side of the dashboard and then on "Documentation".

I had already done these steps. However, when I hit save I get the error i mentioned above. I am using a gmail account to send from and verified the settings are right. I know my credential entered are correct as I can login with them. Still get this error.

Hello @jlbreaux

Can you please run down through these steps and see if you everything is configured to allow from the gmail account?
Looking forward to your reply.

Also be sure that two factor authentication is turned off for the gmail too. Won’t work without the app authorization process being completed if you use two-factor authentication for account access. I use gmail as well and have no problems if set up on Gmail side correctly. Be sure to turn on IMAP/POP in your gmail account as well but I believe the above link covers some of this too.

Relating to the same issue (kind of) what is the command that we need to enter for the SPF settings at our host to stop emails being labelled as spam? The Vtiger documentation states this:

v=spf1 ~all

but I’m guessing that the domain will be different as it is being sent from a Comodo URL. The above command is from the following web page -…_DKIM_settings

Currently any email I send from the CRM is ending up in the junk mail :frowning: so I need to add this.


We have requested for this information to be provided and we will contact you via e-mail once we have the required data.

Can you share the SPF with me as well?

Has anyone had any luck with setting up the email settings with Office 365? I can setup the settings and it will email me the test message, but when I try to send an invoice via the system I get an error message from Office 365 saying unable to relay.

I used to create my SPF record but there are others. Testing now.

Hi Guys, anybody get the SPF settings and configured Office 365? ideal we need the sending IP from the Comodo’d servers then we can add a relay connector…

Cheers, James.

Hi, yes, i can then include a spf or connector in my office 365.

It would be better if they could give you a host name, would save having to keep managing IP addresses for any changes that Comodo make

If you want to user office 365 as your outgoing email settings use this for the server name:

Then user your email address and password associated with the office 365 account and ensure Requires Authentication is checked.