Data: Procedure terminated due to Stopping RMMService

This happens on devices when I run some scripts.

Type of ticket creator: PROCEDURE
Event Created at: Wed Jun 26 06:24:08 2019 GMT+0
Device Name: Astro-34
Logged on User: N/A
Data: Procedure terminated due to Stopping RMMService

Device Data
Domain/Work Group:smart

2019/06/24 03:14:04 PM Failed Terminated Procedure terminated due to Stopping RMMService

Hi @smartcloud ,

Good day!
Which script did you try to use?
How were you able to stop the service?
Stopping RMM service will lead to fail the procedure generally.

I didnt stop the service, this happened while running the script.

The scripts:
one being the Windows maintenance script.

The other one is a script you wrote to run patch cleaner.


Thank you for clarifying. We’ve created a support ticket for the issue you’re having to further assist with your concern.
Please respond to the email we’ve sent you so we can assist you with your report the soonest time possible.

Thank you.

I was getting this error randomly at times, but now almost every script or procedure I run is failing with the same error.
Scripts that had been working now fail.

Is there something I can do to troubleshoot at my end, would it be perhaps the security settings in containment/hip’s?


We have created a support ticket in regards to your report and will reach you via your forum registered email for further correspondence.

have the same problem overhere… running a procedure on Macbooks BigSur… this procedure is triggered when a monitor see that a specific service is not running.
Maybe the Agent is not BigSur proof. I created a support ticket for this so just watching this post

Think it will occur when a shutdown or reboot is in progress and because of that it triggers a monitor that a service is not running and create a false positive, try to execute a script and RMM service is shutting down at that point

I get those a lot also, I automate the scripts, makes me wonder if it is trying to run multiple procedures at once, instead of spreading them out. I run some procedures, then check for last time rebooted, and reboot if it hasn’t rebooted in so many days. Could be initiating the reboot in the middle of my procedures?? I will look into it next time, but that correlation didn’t stand out??


We have created support ticket to investigate the issue.

Kind Regards,