Devices not communicating to Comodo

Hi hopefully you can help me please, we are seeing a number of devices lose connection to the Device List.

Seems to be random, certain devices keep gong unresponsive in the device list.

Is there a good guide to troubleshooting communication issues?

Hello @mattwb

First, we need to identify what endpoint/s are affected or if its random, It could be a problem with your network connection.
You might also try to log in to 2 browsers and check if they are the same when it comes with numbers of Devices listed on your account.

Hi @Jay

Looks to be the same devices on the two browsers I have tried here.
All the devices sit on the same LAN can you help with trouble shooting steps.

Kind Regards


Hello @mattwb ,

I was not able to replicate your issue on my end.
We might need more information about your concern and we will send you an email.

I have this issue as well. I can uninstall the the ITSM agent and reinstall it and it works for a while then loses connection.

Hello @ippathways,

For issues on losing connection, what we would like to suggest is to please check the Windows Services and look for ITSM services and ItsmRsp make sure they are running.
Change the ITSMService to Automatic(delayed) and restart the service and let us know if this improves the connection to the portal.

We look forward for a positive outcome.

Sorry. But setting the above wont help. The ITSM Service should be set to auto. Setting it to delayed has no impact. This non random communication is a known problem we have seen and they seem to be struggling to solve it. Reliability is getting better but you will face these problems.

Hello @ippathways,

Please tell us if recommendations works for you if not we might need to further investigate the issue via email.

@dittoit , thank you for your feedback. We will never stop until issues like this is resolved.


@Jay that seems to have worked! Thank you so much for your help!

@ippathways ,

We thank you for your sharing feedback. We’re glad that the recommendation worked.

I again have endpoints online in ITSM but not online in CRC however remote access works when started from ITSM.

Hi @dittoit
May we ask, from your observation, how long it has been behaving like this? That is, after the recent outage with the CRC.

Noticed it since the last update. I also still have blue devices.

Hi @dittoit
We created a support ticket for your concern. Please do reply at your convenience.

Correct @dittoit, Automatic(delayed) makes no difference. However, I think I’m seeing far fewer of these issues, but still some machines in the ‘connecting’ state. I need to message development to schedule a further remote session for them to collect logs from a system I think they left in a debug logging mode.

@nct ,

We will have our development team reinvestigate on the occurrence of the issue. We will create a support ticket for this case

We find that CCC does not connect to server on nearly all devices we maintain meaning ITSM is pointless and CRC useless.

It we log on and force stop the ITSM service and restart it all comes back to life and we can monitor and manage a machine again, until the next morning as they have turned the computer off and on again like a normal office worker would.

Hard to be an MSP when your tools are lacking.