End Point Manager stuck on Provisioning


I signed up for Comodo One about a week ago and since then the End Point Manager has been stuck on Provisioning. Whenever I click on Applications it has a little whirling circle indicating that it is being installed. It has been like this for around 7 days now. Ive tried signing out, clearing cookies, clearing cache, signing back in, different browsers etc and it is still stuck in this provisioning mode.

I am unable to enrol any devices. I tried seeing support an email, but all they did was get someone to call me and give me a sales pitch. Which was quite ironic because the sales agent swore the software works flawlessly and has little to no downtime. Meanwhile the end point manager is still unusable and stuck in provisioning, he didn’t have an answer for it so the call was ended.

Any ideas on what I should do next?

Thanks for getting back to me, I am registered on Comodo One Enterprise

@macOSWolf ,

Rest assured we can help you with this. We have created a support ticket on your behalf to have our Development Team look at the backend process and have it resolved this minor glitch immediately. Please check your forum registered email at your convenience for some private account details we will need for your portal.