endpoints appear offline in itsm dashboard. stuck connecting to server

Is anyone having issues with itsm being offline in the dashboard even though the machine is online.
They are constantly failing to connect to the server.
Sometimes running the itsmservice.exe from within program files fixes the issue and other times running a repair from program features on the rmm agent fixes the issue.

I have tried setting itsm service to delayed start as suggested in posts from over a year ago but still having the issue.
I have spent hours with comodo and all i have been told is a windows update is turning off the service.They have just advised the fix is to reinstall comodo.
Surely there must be a fix for this by now?
This is costing me hours of work to drive around to all of my customers as i then cannot remote in, and i also look like a fool as it is happening once a week on some machines

Hi @craigplant
We created a support ticket for your concern as we may need to ask from you some possibly sensitive information. Feel free to reply at your convenience.

This has been a long time problem. Its has improved massively over the past few releases but there seems to still be an underlying problem somewhere.

Yes its getting frustrating. I am now being told it must be a firewall blocking the communication to the server which is obviously incorrect as restarting itsmservice.exe normally fixes the issue.
Its a shame as i am really liking the platform

Hello @craigplant ,

Thank you for your feedback and we understand where you are coming from, we already sent a follow up email on your support ticket
to gather some logs and information from the endpoint to further analyze the issue.
Please do reply at your convenience.


Hi, We’re seeing very few problems with ITSM (CCC) not connecting and normally on machines not rebooted for many weeks. A reboot then addresses the issue.

the last two or three releases have been rock solid and solved with the above. Only problem we have is getting the CCC updated as they do not connect and getting to site can be a long way away.

Rebooting is fine for a desktop, but servers can’t be rebooted all the time just to fix an app issue, especially one that is for us and not the client. This issue needs to be resolved.

You only need to restart the ITSMService.

Had it happen on a server as well, restarting the service did not fix it, had to reboot in the end…
Not good for an rmm system at alll


We regret to hear that you are still experiencing this issue. We have created a support ticket to investigate the rootcause of the issue. Support will get in touch shortly.

It seems as if this support ticket has been open for 18 months. I’m having the same problem, but I’m starting to wonder if anyone works at Itarian. Has anyone else ever gotten a resolution from them?

@techiron ,

We have checked with forumer @rockowwc and found that he has not provided a response from our support team. There are a couple of reasons for devices triggering an offline status (random, all or some) 1 a network firewall in place that possibly blocks some of Comodo’s IPs or ports 2 Duplicate devices (reflected by an “unknown device” appearing on the EM portal 3 ITSM service not running on endpoint - this services communicates with the portal to show real-time status of device 3 3rd Party AV, built-in security applications which prevents the ITSM to function properly. Itarian Support Team are indeed available to assist Itarian MSPs,you can send them an email directly @support1@itarian.com, and attend to your concern the soonest time possible.

Thanks for the quick response! :slight_smile: I will look into this.

hello @craigplant Please could you share with us the solution you gave to the problem. thanks…

Hello @Nelson_Fereira. it was a long time ago now that I had this issue and after a few release updates I do not seem to have this issue so much anymore. The fix I used when this happened was to uninstall the firewall driver and reinstall. I was told this issue was an update which installed the incorrect version of the driver. There maybe a post if you search the forum for this however you shouldn’t be getting the issue anymore so might be wise to contact support as it maybe a different issue.