Error when installing the ITSM Linux agent


I read today that the next release will include important updates to Linux side (kudos btw!!!) - so while waiting for the release day I tried to install the agent for further tests, however I got the following error:

XXXXX@Lenovo-G780:sudo ./
[sudo] password for XXXXX:
Verifying archive integrity… All good.
Uncompressing Linux ITSM Agent 100%
systemd system
./itsm-linux: /usr/lib/x86_64-linux-gnu/ version `CURL_OPENSSL_3’ not found (required by ./itsm-linux)
Can’t enroll
XXXXX@Lenovo-G780:~/Downloads$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

I removed the enrollment code (d???F) on purpose, so this is not an issue.
So the error is ‘./itsm-linux: /usr/lib/x86_64-linux-gnu/ version `CURL_OPENSSL_3’ not found (required by ./itsm-linux)’ which seems to be related to the fact that the library libcurl4 doesn’t have a version for 64 bit OS (found this forum that says more about the issue:…-found.204577/ ). As it can be seen in my next command, I use Ubuntu 18.04.1 LTS, however I plan to upgrade this laptop to 18.10 so if this can be fixed for 18.10 as well would be awesome.

Any thoughts on this?


Hello @linux_user
The short of it is that Ubuntu 18.04 (Bionic) is still not officially supported in the current build of the ITSM. Rest assured though that the product development team is working on including newer versions of the Ubuntu distro (and other Linux flavors) in the officially supported platforms. Please check in ITSM → Settings → Support for a list of officially supported platforms in the ITSM.


Install this -

sudo apt-get install libcurl4-openssl-dev

Hope it helps