Failed update broke Comodo Endpoint Security.

I’ve got a laptop with Comodo Endpoint Security 10.0.1, managed through ITSM and the portal. This computer cannot access the Internet or LAN for the past 5 days, and when I checked it today, the install of Comodo was broken. I’m assuming it was a failed update, as I had a folder:

C:\Program Files\COMODO\COMODO Internet Security - old\

but I did not have:

C:\Program Files\COMODO\COMODO Internet Security\

I’ve seen this before with failed updates, and have always been able to fix it by renaming the " - old" directory to its original name, rebooting, and running the update again.
I also assumed that this was the source of the network failures the network filter drivers would be unable to load when they’re not in the right place.

However, in this case, I’ve renamed the " - old" folder, and it still won’t run. When the computer first boots, I get the error message about the Comodo Agent being unable to start, do I want to run Diagnostics to fix it. If I click Yes to run diagnostics, the dialog disappears for 0.1 seconds, then returns, in an endless loop.

Attempting to uninstall CES from the control panel immediately throws and error stating that the uninstall failed because of an error. I checked Services in computer management at this point, assuming the Comodo services were not running properly. Turns out, they were missing entirely.

I’ve got a few installers for version 8.3, 10.0.0, and 10.1 of CES, so I’ve tried to install a fresh copy over the old one, but none of the versions I have work.
The command line I used is:

msiexec /q /i CES_x64_10.1.msi /lv ces_install.log

It starts doing something for a couple of seconds, then stops. I didn’t really expect teh 8.3 and 10.0.0 versions to work, as it would be a downgrade from what’s already on the machine, and probably not a supported migration path.
The 10.1 version also failed, and the log file is attached.

Is there a way to do a repair install, or an uninstall tool like a Symantec, AVG and others have? I’ve found an unofficial third-party one for Comodo, but it looked like it hadn’t been updated in a long time, and I’d rather use an official one if such a thing exists.

This computer still works for working with local files, but all network access is blocked. I can’t even ping the computer’s own IP address; although, maybe surprisingly, it does actually get one from the DHCP server.

What can I do to fix this?


ces_install101.txt (32.1 KB)

Hello @cbox
You can try the Microsoft FixIT tool for installation/removal issues to remove the listed CES from the system. Afterwards, you will be able to reinstall CES.

Ran the tool, and it removed CES from the installed programs list, but still wouldn’t install again. Rebooted and tried to install, same issue.

Installer logs from both before and after reboot are attached.

ces_install101-afterreboot.txt (32.1 KB)

ces_install101-beforereboot.txt (32.1 KB)

Hi @cbox
Is CES still listed in Programs and Features? If it is, you can run the Microsoft FixIT tool again and choose installation and look for the CES entry. If it is not, you can still use the same tool, choose Installation, and check if CES is listed in there. Please do inform us of whatever the result may be.

I’m not onsite where the computer is anymore, but will be again tomorrow. However, I tried both of these before leaving. CES wasn’t listed in either case.

@cbox Do you have the CIS Removal Tool to force an uninstallation of Comodo Client Security? If you don’t, contact support and they can run it with you to help remove the application.

No, I don’t have any removal tool. That’s one of the options I was looking for in my initial thread post, since I couldn’t find one through GoogleFu. I’ve sent an email to c1support, so I’ll give that a try and update with results.

Hello @cbox ,

Yes, we have responded on the support ticket you have sent us. Thank you.