Firewall blocking access to Quickbooks

I opened the ports required by quickbooks according to their documentation here:

  • QuickBooks Desktop 2017: 8019, 56727, 55373-55377
but for some reason the firewall keeps blocking it. Also when I select disable firewall permanently to allow access (which worked) the firewall turns itself back on again within a matter of minutes (3-15 min).

Is it a know issue for the firewall to re-initiate even after disabling it?

For disabling the firewall, @greenshieldtech, the behavior you observed on the endpoint side is correct. This is because the security-related settings in the profile assigned to that endpoint is the one that is constantly in effect. To override this from the endpoint side, you first need to set this in the ‘Client Access Control’ section of the assigned profile.

For the QuickBooks (or any other applications), we suggest that you allow it through the ‘Application Rules’ sub-section in the Firewall section of the profile. No specific ports are needed, just the correct set of files (or folder path). You will have to create a new file group first (like ‘clientA’s proprietary software’). Then simply choose the ‘Allowed Application’ ruleset for the applications group.

Of course, if you still prefer the port method, please read the Citrix example in the wiki guide.


Did @Rick_C 's solution work for you? I have a client with same issue. I have disabled firewall in the profile. I’m hoping the solution above works so I can re-enable firewall.


Hi @ntelogic
Feel free to try also the suggested settings on a test machine so you can know for yourself.