Help! RMM bricked my android device?

Hey all,

We just deployed our first android device and it hasn’t exactly gone as planned. I installed the apk, opened the enrollment URL, had the device show up in RMM, and then my troubles began…

I kept trying to activate the device via the app, but I was repeatedly told that there were additional permissions and stuff required. I went through each of those and cleared them until the only one left was activating the device. Unfortunately, telling it to activate wasn’t working so I hit cancel. That brought up a prompt that reads “To Disable Device Administrator enter administrator password or contact your system administrator.” What on earth is this password? Not being able to figure it out, I tried rebooting. No dice. I then tried deleting the device from RMM and rebooting again. No dice. So now I can’t get out of this screen and I defnitely don’t know the password.

How do I get my device back?!?

Is it already enrolled with a google account? If so, try using Google’s find my phone feature to remote wipe it.

Hello @brodkin ,

Can we know the exact version and model of the device you are trying to enroll and can we verify if this is for old RMM?
Is this the first time you have tried to install 3rd party software on your android phone?

@indieserve , thanks for your suggestion


Unfortunately, the device is not enrolled with Google. In fact, these Android boxes are super stripped down with only a handful of pre-installed apps. They are manufactured by a small company called DSDevices, but handle third-party software beautifully—until now.

Does anyone know where one gets this mythical password?

Hello @brodkin ,

To further investigate the issue, we will create a support ticket for this.

Thank you.

Yeah I have a user that has had it installed for a year now and all of a sudden its locked out. I never set a password and the device isn’t in my management portal.

I’m very pissed that this has happened with no option but to factory reset.

Hi @sege5641,

We apologize for the inconvenience, however we would like to clarify a couple of things.

By “had it installed”, could you clarify which Comodo app was installed on the mobile? Was this the Old RMM or ITSM?

You also mentioned that the device was not in your management portal, do you mean that the device was not enrolled on the ITSM portal when the issue happened?

One last thing, was the issue resolved when a factory reset was performed?

Thank you.