Install cWatch EDR


I’ve tried to deploy the EDR client using this script:…modo-edr-agent

When the script is run it fails with the following error:

Traceback (most recent call last):
File "<string>", line 7, in <module>
File "C:\Python27\Lib\", line 26, in <module> import socket
File "C:\Python27\Lib\", line 47, in <module> import _socket
ImportError: DLL load failed: %1 is not a valid Win32 application.

Can someone resolve the error or provide an updated version of the script that we can use?


Hello @hamish

We will take a look on this and supply the script link as soon as possible.
Thank you.

Hello @hamish

It is working in our environment. Please take a look on attached images for references. Try to re-install (Comodo client communication) and try once. If still, the error persists we will assist you with the remote session.


Thank you.

I’ve deleted and recreated the script in C1.

Running it against the target machine the script fails with the error above. Running it against our test machine it is successful.

The only difference I can think of between the two devices is that the target machine is running Windows 7 and the test machine is on Windows 10. They’re running the same profile otherwise.

Thanks for your valuable evaluation @hamish . Will recheck on multiple platforms and provide you the script.

HI @hamish

we have tired the same script with different environments and received the positive results. This error does not relate to the script so don’t recreated the script in C1 make sure to Re-install Comodo Client communication agent on the error encountered system. still, if you’re having any problems with that we will bring out the error for you with the remote session.


Thanks for investigating. We’ll try re-installing the agent.

On a related note, when the script does complete successfully on our test machine it doesn’t seem to actually install the EDR agent.

We’ve tried:
Remove the manually installed EDR agent
Restart the computer
Run the install script
Wait for successful completion
Restart the computer

The EDR agent is not showing in the programs list of the test machine and does not appear in the EDR tool.

@hamish ,

We have sent a follow-up email on your forum registered email. Please check your mailbox at your convenience.