Itarian login broken (again)

What is going on with Itarian? gives the message “Something went wrong, please try again later” when trying to log in and Remote Control by Itarian gives the message “server retrrun error with code undefined”

Your service breaks more than anything else I have ever seen, paying customers rely on this software.

This appears to be a geographical issue in nature as I can log in to Itarian from Eastern US but not from Western Canada.

Web login now working however Remote Control by Itarian still not working

Hi @terry.r,

Sorry for the trouble you faced. Can you please verify if you still have any issue.

Kind Regards,

and again…


Anyone else having problems with login into the platform again at present?

Yea I can’t login again either this morning

Seems to be happening far too often at present. We pay for this service and the very least we deserve is an explanation.

Couple of weeks ago reason was explained as a corrupt DB. Would be interested in knowing the reason for the last few platform outages.

I suspect they dont have 24h staff for the platform as issues sometimes take a long period before being noticed. As per this one now being over an hour with no recognition or notification in the service status page of the problem.

Agreed. Working in IT we understand problems occur, but communication is vital. If I had to guess, maybe this is related to the corrupt DB and they having more residual issues than they first realized. Not sure what their setup is, but I’ve dealt with some DB corruption that caused alot of pesky issues later on, especially doing future upgrades…etc. I’m sure they will get it under control, but more communication is definitely needed.

EDIT: And as I post this, I’m now able to login

Hi, We cannot login to either. if it is a db issue then please fix.

I’m still getting the CAPTCHA followed by the dreaded ‘Something went wrong’

Seems to be regional or just very random. I’m in US Eastern

Yeah Europe here and still cant get in. coming up to three hours now yet service status still not aware of the problem.

Europe here too and same issue for some users.

Odd thing… (luckily) just walked into a different office and one of the computers is still logged into the platform, so at least we can enrol the new endpoints. Still unable to login though from other computers. 3.5 hours now and still no notification of a problem on Comodo’s service status. Do they only work US office hours?

Resolved for our Europe sign-ins.

Same here… back on the platform. now.

Hello all,

We finally found out the root cause and applied the necessary fixes on our SSO servers. There shouldn’t be any issue left both with ITarian and Remote Control authentication. We are sorry for the inconvenience caused. You can check details from

Best regards,

Had the same issue, no login to US server.

Resolved now, but frustrating when trying to assist end users who pay me for a service.


Still having problems over the last two days with intermittent failures login in to both the platform and the remote control.

Sometimes it’s the usual ‘Something went wrong, try again later’ and other times it’s the captcha then username/password mismatch.

I’m now also receiving the message ‘server return error with code unidentified’ from remote control.