Moving device from one MSP C1 account to another

There was a script used to move a device from one ComodoOne account to another which required the link with the token to be used (Destination), and the script uninstalled everything , and reinstalled the agent from the new comodo1 client. This worked a few months ago, but when attempting to run the script again today it only rebooted the machine but the comodo security was still installed and agent still remains in the source account. I’ll have to try again on another device but wondering if this script needs to be updated since last time?


@evoevoevo ,

We assume you are referring to . We will forward your report to our Script Developers to have it reviewed. Can you please share as well the output of the logs and OS environment where you have executed the script?

Hi @evoevoevo

The script is working fine on our side. Could you please share the output logs and tested os environment?
It will be more helpful to sort it out and proceed further

Thanks in advance

Actually it was another script. . . I’ll try this one. . . BUT in any case the original script I used successfully removed the comodo software from the source---- which logs could I send after this occurs?


@evoevoevo ,

Thank you for your response. Please give us the output of your tests and we’ll make sure our Script Developers are informed of its outcome.

The script you pointed me worked fine. I do have another question though – with this script if the source endpoint only had the Comodo communication agent installed but not the Comodo security package —will it be installed at the destination or will it be left out as well in the destination account?

No, it will not @evoevoevo. The script is mainly to transfer an enrolled device from one ITSM account to another ITSM account.

Yes I actually just noticed this script also doesn’t require a reboot like the old one did. However I watched as this occurred on a client machine- and in spite of running as a system user, there was a moment where the comodo gray screen popped up on the desktop stating it needed to be registered to an account (the one where there are prompts for the host link/port/token), and went away after about 5 seconds as the script continued. IS there any way to suppress this popup so there is no disruption to an end user?

Also for MACS, does an APN certificate need to be installed/configured on the destination account to work - or will it work because it was already done on the source account? I’ll have to read about the APNs as we’ll need to create a new one for the new account at some point anyway.

And one more – if there is an Acronis backup agent also associated - - is there a way to move that to a new account as well keeping the same job configurations and such?

@Rick_C - Thank you.

What would you recommend be the best course of action with the MACS, since there’s a 2 step process in assigning them – what would be the steps to reassign accounts, or should we just completely remove / redo?


Hello @evoevoevo
This is part of the migration notes provided by the developers (which is also applicable to your inquiry).

  • ITSM (macOS / iOS devices) - Due to an Apple limitation these devises cannot be migrated they will need to be re-enrolled.

We have sent an update request for your inquiry @evoevoevo to the product development team. We will post here the team’s reply as soon as we get word from them. We appreciate your patience on the matter.

Just checking in to see if there is any update.

thank you