New CCV dont work

Old problem in new design

Connecting… -> Connected … -> Disconnected and error

Hi @Sergey

I have forwarded your bug report to our support team. They will contact you with updates.


I’m getting the same problem as @Sergey - CCV gets as far as “Connected to the peer via TCP Relay” then fails with the same message as Sergey. Trying to connect with RMM plugin I get the message - “Device is already in session with another client”. Tried with a number of connected devices. Stuck without a connection to my clients!

I’ve tried updating my CCV client and looks like this has been updated but still not connecting. All clients computers have been updated with latest ITSM module.

Update - RMM Plugin now appears to work but CCV still does not. Think I have spotted a common issue. The ITSM modules on the clients PCs all say ‘Connecting to server’ when you hover over them in the taskbar. The computers are communicating with the server so much as to tell the server that they are online or offline but it does not seem to be allowing the CCV module through to start a remote connection. So not sure if this is a Comodo server side issue or the client side ITSM module.

I’m new to the C1 RMM platform. I am testing it on three systems in our office, two WIN10(64) laptops and 1 WINxp workstation. One WIN10 laptop and the WINxp desktop are working well, the other WIN10 laptop repeatedly suffers from the behavior matthell describes - ITSM client doesn’t move beyond “connecting to server…”.

Something else I’ve found on the affected laptop, the ITSM client will work normally until another program is installed or uninstalled. Once the installer completes, ITSM client has changed to “connecting to server…”.

Thoughts??? Suggestions???

The issue seems to be that the service “ItsmRsp” is looking in an old location for the .exe. It’s looking for “C:\Program Files (x86)\COMODO\Comodo ONE Client - Communication\ItsmRsp.exe”, but it should look for “C:\Program Files (x86)\COMODO\Comodo ITSM\ItsmRsp.exe”. Can we get this patched ASAP?

You can (at your own risk) run the following commands on client machines to get it working until Comodo fixes it. "SC CONFIG ItsmRsp binPath= “C:\Program Files (x86)\COMODO\Comodo ITSM\ItsmRsp.exe -service” && “net start itsmrsp”

Hi @matthell , @Mattk361 , @SecuraDM

I have forwarded all your feedback regarding client viewer connection issue to our support team. They will get in touch with you shortly.


Hello @Sergey , @matthell , @Mattk361 , @SecuraDM ,

We have contacted you over email regarding the issue reported above.

I rarely use CCV. It does not have all the capability of the RMM tool, such as file transfer. It also still seems buggy as others are mentioning.


CCV still having issues is there an eta on a fix?


We needed to tweak the syntax a bit but we were able to get this to work on several endpoints using an elevated command prompt. The line we used was:

SC CONFIG ItsmRsp binPath= “C:\Program Files (x86)\COMODO\Comodo ITSM\ItsmRsp.exe -service” && net start itsmrsp

Now we’d like to run this as a script via Comodo One MSP procedures, but we’re not familiar with the scripting language. Could someone let us know what we need to do in order to convert this to a script?

Hi @TrevorM

Please use below script in C1 ITSM to fix issue in both 64 bit and 32 bit operating systems.

To execute script procedure in ITSM, Please refer WIKI Topic…ure-in-devices

Please let me know, if you face issues,

import os
import time

query_service=os.popen('sc queryex ItsmRsp | findstr "PID"').read()
pid=query_service.split(': ')[1]
kill_service=os.popen('taskkill /F /PID '+pid).read()
del_service=os.popen('sc delete ItsmRsp').read()

if 'PROGRAMW6432' in os.environ.keys():
    create_service=os.popen(r'sc create ItsmRsp binpath= "\"C:\Program Files (x86)\COMODO\Comodo ITSM\ItsmRsp.exe\" -service" start= auto displayname= "ItsmRsp Srver"').read()
    create_service=os.popen(r'sc create ItsmRsp binpath= "\"C:\Program Files\COMODO\Comodo ITSM\ItsmRsp.exe\" -service" start= auto displayname= "ItsmRsp Srver"').read()

start_service=os.popen(r'sc start ItsmRsp').read()

20170218-Restart-itsm-services-update.json (1.41 KB)

I’ve tried this on a few endpoints and still can’t connect using CCV. One of the endpoints shows this in the Procedure Log:

2017/02/23 11:46:50 AM Finished success PID : 2884 [SC] DeleteService SUCCESS [SC] CreateService FAILED 1072: The specified service has been marked for deletion. [SC] StartService FAILED 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Hi @comtech

Could you check the command shared by @TrevorM

SC CONFIG ItsmRsp binPath= “C:\Program Files (x86)\COMODO\Comodo ITSM\ItsmRsp.exe -service” && net start itsmrsp

I can provide script for this alone and attached with this post.

Thanks ,

20170224-ccv_temp_fix.json (1.54 KB)

This procedure runs successfully but I am still not able to connect with CCV.

I can not even log into any endpoints, tells me login in error through the admin panel, and CCV gives me the same error as you are stating here.