New Companies created in the C1 Portal are not appearing in the ITSM

When we create new companies in the portal they are not populating into the ITSM. We are also unable to delete any company currently in the ITSM even though we have deleted them from the C1 portal.


Just to make sure that this is not client-side, which browser did you use to view the C1 Portal? Have you tried to optimize the browser? Or perhaps have you tried to view the C1 portal using a different browser (or on a different device)?

We have tried using multiple browsers. IE, Firefox and Chrome and on different computer systems. We are able to create Customers, delete customers, create tickets for the newly created customers but these customers do not populate in the ITSM and therefore we are unable to assign devices or utilize the bulk installation packages.

Hi @hsdssupport
We created a support ticket for your concern. Please do reply at your own convenience.

Ok I can recreate this exact issue. If you create a user in the Comodo One Portal, it appears in the ITSM as a company. If you REMOVE the customer from the portal it is also removed from ITSM. You cannot re-add the same user with the same name. The email and addresses can be the same or different from the originally deleted user.

Hello @c2technology

We tried to replicate this issue. What we did was create a new Customer in the Comodo One portal. It did appear in ITSM. We tried to remove the same and add it afterwards and we were able to add it again, with the same name and email.

Could you please clarify what you have experienced and send screenshots?

Thank you.

@Riley_C @c2technology I ran into this when I first started using it. Did you enter any special characters like Ampersands “&” in the customer name. I found that “&” breaks the creation of the customer in ITSM by not creating the “Default Group”. I think other characters may have similar issues. The Dash “-” does not have the issue however.

I also found I could not recreate a customer with the same name the first time I ran into the issue. I deleted and tried recreating it thinking that maybe it didn’t provision properly but it failed.


2017-11-26 00_28_01-ITSM_nodefaultgrouponspecchar.png

Re-added users are visible everywhere except the drop down menu for bulk installations.

Hello @c2technology,

We will momentarily send an email regarding this issue to gather information and resolve the problem.

Thank you.