Opening TCP port 5900

I am sure this is a simple step, but for the life or me i can’t get it to work. All I need is to open port 5900 on all endpoint for a client. Their internal IT uses VNC internally. I have taken the following steps but nothing.

1 - Under Profile i select the profile with firewall
2 - Create a new global rule that looks like this:
3 - Action - ALLOW
4 - Protocol - TCP
5 - Direction - in
6 - Source IP - Any Address (anyone can connect)
7 - Destination IP: Any Address
8 - Source port: ANY
9 - Destination port: 3389

But it does not work, i do see the rule on the client, also if i turn off the firewall it works fine.


Hi @rudym12 ,

Can you allow the following rule under the Application rules of Firewall?

You may also check our help guide using this link: