Patch Management istallation issues

I am new to Comodo and am having some issues with Patch Management.

I have created two new company’s, one for my business and one for a client, they both appear in RMM but I only see my company in Patch Management on the menu bar and admin menu. My company name on the menu bar appears to be a hyperlink but goes nowhere when clicked.

Using the Quick Start guide, I have tried to install the agent on one system that never appears.

Any guidance would greatly be appreciated.

Thank You.


Hello Kevin,

My name is Harvey and I am one of the COMODO Enterprise Technicians.

Technically, if you click on the company name from the Patch Management console (you can easily locate it by the icon representing three people on the upper right corner), you will get a drop-down list with the rest of your companies.

However, if one of the companies added in the Comodo One console (Management - > Company) is not showing up, please start with deleting and recreating the company entry and log out and back in.

Also, please retry the agent installation by following the steps from the below links:

For Patch Management:

For RMM:

Please let us know the outcome.

Also, if you have other Comodo One questions or issues, you can also contact us at

Best regards,

Thank you for the response Harvey. Logging out and back in again helped.

I was able to get the agent installed on one of my company computers and can see it under agents, however I have not been able to get the agent installed on any other system, even copying the command I used to successfully install the agent on the one system that I was able to get it to work.


Hi Kevin,

Please make sure when running the command for the agent installation, the correct path to the *.msi file is in front of the package name.
For example , if the agent is saved in “downloads”, the command line should look like this:
'msiexec /i c:\downloads\c4agent.msi /qn USERNAME=… ’

I am not getting any errors when I run the command, it successfully executes. I can even run Patch_Agent.msi again and am prompted if I want to do a repair or removal, both of which I have done. I have rebooted, reinstalled. I have done everything I can think of.

The agent appears to be successfully installed, the agents are just not “checking in”.

As I said I have gotten one agent installed and got it to “check in”, although when I click on it, it now says “Agent Down”.

Hello Kevin,

Can you please confirm that you see the Agent in Programs and Features ?

I have done a clean install of the Patch Management Agent as well to test the process and it works. You will not get any errors as the command triggers a silent install.

Try and download the agent again just to be sure you have the latest version.
Please try and use the “/l install.txt” at the end of the command line to save a log of the installation for debugging.

Please make sure that you allow it to run if you have any Antivirus or Security Program on that machine.

Please advise the outcome.

Yes I can see “Comodo One Patch Management Agent” in Programs an Features.

The last few lines from the install.txt:

MSI (s) (14:FC) [01:16:44:005]: Product: Comodo One Patch Management Agent – Installation completed successfully.

MSI (s) (14:FC) [01:16:44:005]: Windows Installer installed the product. Product Name: Comodo One Patch Management Agent. Product Version: 2.0.695.0. Product Language: 1033. Manufacturer: Comodo. Installation success or error status: 0.

Hello Kevin,

Have you tried to install a new copy of the agent? Also, do you have any security programs that could prevent the program from running?

Also please make sure that ports 80, 8080, 443 are opened.

Looking forward to your reply.

Yes I downloaded and used a “fresh” agent, version 2.0.695.

No warnings were presented by any security measure however, all security features have been disabled including firewall and antivirus.

I have tried on multiple systems not just one

Hello Kevin,

Can you please try and check the Patch Management Console in Mozilla Firefox? The Chrome and Internet Explorer might have issues with the User Interface.

I have been going back and forth between Chrome and Firefox. I gave up on IE when the company would not change.

Hello Kevin,

We can continue the conversation in the ticket. Since some files might be required.