Patch Mangement doesnt download/deploy when installing

I have been using the generated install codes to download and install the RMM and patch management. The download of the installer works, and it installs the RMM portion but pops up an error that it can’t download the patch management module.

Happens about 95% of the time. (I have a couple of locations that it worked, not sure if I did anything different.)


Hello @Velvis

If you already have RMM installed, please follow the below steps:
In the RMM Console, go to Procedures, Create a new procedure and use the Application Installer action.
Inside Application Installer you have the possibility to choose Install Type: Patch management install.
That is predefined, so nothing more to do but save the procedure and run it on the desired machines.

Please keep in mind that Patch Management agent might show up in the Patch Management Console with a delay of 10 - 15 minutes.

This did seem to work a couple of weeks ago, but I tried to roll out patch management to a set of computers and either it never happens or I get kicked out of the RMM Admin Console saying I have disconnected when I try and run the procedure.

Hello @Velvis

Are you trying to deploy the PM agent by using the RMM procedure? If so, can you please tell us more about the result in which it does not install it?
Does it give you an error on the endpoint? Or when it disconnects does it prompt you with an error?
Looking forward to your reply.

I tried it, but there is no progress or signs of job running.

Hello @Rickkee ,

We have contacted you by email regarding this issue, please get back to us as soon as you can.

I have also had success using the install msi function from the ITSM device page, I just put the URL to the installer on the comodo site and copy the parameters after the .msi in the install string and have got 2 different computers working that way


In theory the procedure you used should work fine and we are glad you had success with it. If there are issues encountered you can post them here or send an e-mail to

I learned that the default command line in Patch Management module contains the switch /qn which means silent install.
If a patch_managment.msi failed or is not showing up, running the script wont fix it.

I downloaded patch_manager_agent.msi from the PM Module to a temp folder and run the command line given in “Downloads” I can remove /qn and get prompted to
Repair or Uninstall. I uninstalled the agent and reinstalled it from command line to get it working.

Perhaps the Comodo script can check to see if an agent is installed, uninstall it, then install the patch?
( I don’t think it currently checks or uninstalls because the push method from ITSM didn’t work in this case)

To find the patch_agent.msi and download to temp folder.
To run the agent command line, right click over msiexec /i … select all and copy to clipboard, paste into admin CMD prompt.

Uninstall - msiexec /x patch_agent.msi
Install manually from console - remove /qn

2016-08-09 18_24_42-Comodo ONE.png

Hello @Rickkee

Yes, the command does contain the silent install argument which usually makes the process smoother and without user interaction.
You said that you downloaded the msi file in a temp folder but you ran the command from Downloads which is contrary to the instructions provided on the download page. The command needs to run from location of the file.
If you see that the agent is nor working on a machine then you can uninstall it from Programs and Features. Removing the /qn will open the GUI but using it requires the same level of interaction (you need to access the machine) as the manual uninstall.

The modification of the script to uninstall existing instances will be forwarded as a Feature Request.