Patch Procedures says finished successfully but nothing installs

When I run a patch procedure on a device that lists patches are available. It shows the procedure as finished successfully in the patch logs for the device, but when I look into the log it did not even attempt to install anything and the patches are still needed. I tried this on two different devices that needed patches and both did the same thing. I also tried running the default patch procedure instead of my made one, but it did the same thing still. Anything other ideas to try?


Hi @Damon C

I have heard that before on how the ITSM patch management works. But there definitely seems to be some bugs in the patch management and seems there have been for a while. I know you guys are working on improvements though.

But an example of this not working right. I had a device that said it needed 13 patches. So I did a push for the patches. It said completed successfully but nothing installed. So I went to patch management directly and installed one of the patches. That patch now shows as installed, and it now says there are 12 patches required in ITSM. So there must have been some kind of an update to occur for ITSM to switch from 13 to 12 a bit after I did the one. But why would it not have done the 13 with the original push, or if they would have already been installed why would it have not went from 13 to 0 instead of just going to 12?

There really should be an option to change the timing on this. 24 hour update seems like a long time. Even doing an ASAP update is far from ASAP as it takes up to a couple of hours for the delay and collector work time. Or there should be an option to at least do a force check without having to restart services.


I have a problem too, automatic updates, via a procedure.

2018/04/11 09:58:17 AM
Finished success
Procedure operation succeeded.
2018/04/11 09:58:17 AM
In progress
Resolving Procedure is completed succesfully.
2018/04/11 09:58:02 AM
Resolving Procedure is started.

however all my clients have multiple updates showing, something isn’t working.

I was about to post about this as well, we’ve been trying to get our heads around the patch management and seems as though there are some voids. In our experience - we got the same issue as @dittoit and @RayBTWIT in that there was 7 updates available. We ran the patch procedure from C1 and it said it finished (on one computer it actually did list the patch it installed), and on another just said finished. Both machines still have more updates pending when we manually ‘check updates’ on them. We’re figuring perhaps only ONE patch is applied at a time?. . We also had another issue where nothing would happen at all in the US site, but when we switched to testing in EU’s site - at least we were getting some kind of activity. . .

Same issue here!!!