Problem with Itarian MRC app

I have installed the app on two smatphones with both Android 10. On the Samsung Galaxy the app works regularly, while on the second smartphone, an Outitel C19 Pro, it still does not find a connection, as in the attached screenshot, despite the fact that the connection is obviously active. The app’s permissions are identical on both devices. Any suggestion ? Thanks

Hi @datalink

have you tried removing the app and adding it again just in case the application did not install correctly from the app store?

If this still does not work please raise a support ticket where they can collect required information for diagnostics.

installing it again solved the problem, thank you

1 Like

No problem at all, glad it helped!

Same issue and proposed solution here doesnt work

Hi @Naturalsolutionspe

Could you please confirm you have removed the application after removing the application cache and temp files?

Once this is done you can then uninstall and re-install which should solve the issue.