Remotely updating ITSM Agent

Since yesturdays update I am unable to take of remote control of devices using the comodo client viewer. Getting below error:

“Takeover functionality is not available for the selected device because ITSM Agent installed on it is outdated. Please update ITSM Agent to the latest version.”

Is it possible to update the ITSM agents remotely? I’m not seeing the option to do so anywhere.

Hi @providingit

Please check below Wiki page to see how to update your clients.

In this case, communication client needs to be updated. They are already scheduled to be auto updated, but due to load management on server side, it might take a while to update all clients. You can trigger the update manually as described on the post.

Also, please be aware that you need to update the viewer application as well if you didn’t already.

Please let us know if you need anything else.


Mine is not updating through this method, I have tried several, and none have updated, nor is it showing up in the installation state window??


I’m also having problems and the manual update doesn’t seem to work. I cant understand that the automatic update of the clients is taking so long its been a couple of days now

Hi @Marveltec , @BOSS

Please try again today. It is mostly about load on the server or connection quality on endpoints but If it still doesn’t work, I can give you a trick to update clients.

  1. You can download the latest version of the client (like enrolling a new device),
  2. Strip down the session key from file name (just ITSM.msi is enough for renaming)
  3. Script that to run on endpoints or manually run that on any of your endpoints.

It will update the clients without any dependency to servers.

Normally, this is not required by I understand the issues you see and urgency. So, might worth it.


Still does not seem to be working for me, but I did not try the trick you suggested.

Hi @Ilker, @BOSS ,

ok seems like most automated updates have completed now have had a couple of issues with some endpoints not updating and not liking the manual method either but after logging into the endpoints via different remote access software and doing a repair install of CCC it works. not really ideal

Ok im having this same problem and I cant seem to figure out how to get it to work. I’ve tried uninstalling and redeploying, repairing. and I cant initiate a remote session without it saying “ITSM Agent installed on it is outdated”. It actually shows that the ITSM client is fully updated.

Hi @tekcc
As of this post, the latest version for CCC (for Windows) is 6.14.9529.17120. Is this the same with what you have on the affected endpoint?

You may also try to ‘remove’ the endpoint from the ITSM portal and re-enroll it back.