Script Needed | Install Webroot

I need a script to install Webroot. The download url is below and I need a section in the script to add msi installation parameters.

Hello @rawtech
There is a script available that can achieve what you need: Check application installed if not, download and install it

Please feel free to reach out to us if you need further assistance or clarification. Thank you.

I managed to get the script to run successfully but the software never actually installs. I’m wondering if it’s due to local user permissions. Is it possible to run the script using specific credentials?

In the linked script in my previous post @rawtech , it is specified there to run the script as a ‘System user’. When you run the script, in the pop-up window that comes up, it will have two radio buttons for the two options ‘run as LocalSystem user’ and ’ run as Logged In User’. Make sure you select the correct user (system user).

@Rick_C I’ve tried that and it does not successfully install the software. Is there a way to use domain admin creds?

Honestly, the ‘Local System’ user has higher ‘access privileges’ over any administrator (local or domain).

In the script, there are variables that you can customize and one of them is the ‘DownloadPath’. You need to make sure that the ‘DownloadPath’ is NOT affected by containment (assuming CCS is installed on the target endpoint and Containment is enabled) as this will produce no noticeable result. Or one way to interpret it is to make sure the ‘DownloadPath’ is excluded from Containment.

Hi @rawtech

Could you please ensure us the software downloaded on your machine. If the downloaded file seems absence in the targeted path, URL may have wrong. If not, the silent parameters may vary for the software.

Thank you

This is my error log. Looks like the machine is refusing the connection. I’m running the install as the local system user.

Traceback (most recent call last): File “<string>”, line 136, in <module> File “<string>”, line 49, in Download File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 154, in urlopen return, data, timeout) File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 431, in open response = self._open(req, data) File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 449, in _open ‘_open’, req) File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 409, in _call_chain result = func(*args) File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 1240, in https_open context=self._context) File “C:\Program Files\COMODO\Comodo ITSM\lib\”, line 1197, in do_open raise URLError(err) urllib2.URLError: <urlopen error [Errno 10061] No connection could be made because the target machine actively refused it>

Hi @rawtech

We’ll analyze with your request and update you once it has been completed.

Thank you.

@Prabakaran I’m trying the script on my own machine and it appears that the MSI isn’t downloading. I know the URL works because it pulls the MSI file just fine from a web browser. I’ve tried various download paths.

Hi @rawtech

Please refer the JSON file for installing the webroot.

kindly provide the feedback to us

​​​​​​​Thank you

20180417-webroot-install (1).json (7.26 KB)

The script never worked but I was able to get the Webroot Install to work using the Custom MSI Package Installer Tool.
Below are the settings that I used, replace the GULIC with your own webroot license key. Also, you have to use the reboot option “warn about the reboot and let the user postpone it” or it won’t install correctly.

To deploy Webroot via C1, access the Custom MSI Package Installation tool and use the following settings:

  • MSI URL:
  • Command Line Options: GUILIC=1234-1234-1234-1234-1234 CMDLINE=SME
  • Reboot Options: Warn about the reboot and let the user postpone it.

Hi @rawtech

Refer the attached JSON file for installing webroot software.

Kindly provide your feedback to us
Thank you

20180420-script-to-install-webroot.json (7.38 KB)

This script doesn’t work. Can you make the script run the following in the exactly order the switches are in? The /qn switch absolutely has to be at the end of the syntax.

msiexec.exe /i wsasme.msi GUILIC=1234-1234-1234-1234-1234 CMDLINE=SME /qn

@rawtech ,

We have forwarded the outputs of your test to our Script Developers. We will provide you an update on the progress of the modified script.

Hi @rawtech

Sorry for your inconvenience, I have created the script as per your comment.
Refer the below JSON file and achieve your need.

Let me know your feedback.
Thank you

20180618-script-to-install-webroot.json (7.33 KB)