Service cant start Server 2012 Essentials

When installing the agent, the service fails to start and I am unable to complete the installation. I tried assigning a different user to it. It just says it times out starting the service.

Thanks for the feedback. We are checking this.

Just a note. Comodo support is working with me right now on this issue.


could you please try to get the new agent and enroll your device again? it should be solved.

Best regards,

I will try that over the weekend.

Just a note. This did not fix my issue, and I have sent two emails in replying to my case for a follow up with no reply.

Apologizes for it Chris,

I will follow up the progress and notify you.


We found out that the core reason is missing Microsoft.Net 3.5 Framework on these machine. You need install it first. I am adding a PDF doc to show how to install on WS2012 and also W8.1 if needed.

Best regards,

Installing Microsoft.Net 3.5 Framework.pdf (1.07 MB)

Installing .Net 3.5 now. I had installed .Net 4.5 a while ago.

EDIT: While look at that. Bloody .Net 3.5 fixed it. Now to test the patching