Shell execute

Ok Guys a couple issues here. When in a session and adding and deleting procedures. The in session procedure list keeps ALL of the procedures in the list, even the deleted ones.

When Creating from, it appears that this process actually moves the current procedure to the new name and names the new procedure with the current name. Almost like it should be “Move this procedure to” instead of “Create from.”

Main goal here:

I am trying to get UVK to run and it seems as though a procedure in RMM is the only place I can’t do it. I did it from command prompt, VBS and Java script. I tied the following under shell execute.

/c start /d “c:\Program files\UVK - Ultra virus killer” uvk_en.exe

/k start /d “c:\Program files\UVK - Ultra virus killer” uvk_en.exe

/c start /d “c:\Program files\UVK - Ultra virus killer\uvk_en.exe”

“c:\Program files\UVK - Ultra virus killer\uvk_en.exe”

c:\Program files\UVK - Ultra virus killer\uvk_en.exe

c:\Program files\UVK - Ultra virus killer\uvk_en.exe

“c:\Program files\UVK - Ultra virus killer\uvk_en.exe”


None of these work… I guess I am just totally not getting how shell execute in RMM should work

Hello, The ‘shell execute’ works as you would have a direct command prompt window, open, on the target endpoint.
This means that everything you can do from the command prompt, on the target computer, should also work from the Shell Execute, on your RMM interface.
Please try running the same commands in remote, in a cmd window, and check if they work.
If they do not, we need to gather some logs , and have this escalated and checked.

Last I knew, environmental variables do not work when using shell execute from RMM admin console when creating procedures, but does if connected to specific computer console.

OK thank you, I will try that and get back to you. Hopefully with the new info it will work sand I was just misunderstanding how it should work.

@BOSS @Charger440 Indeed, some commands do not work. I will make a request for a list of commands that work from the “Shell execute” tool.

Ok, am I not understanding or something. Can someone help with the exact script needed in this case? I too have tried this can nothing I do with any of the suggestions here worked for me.

It runs the program as SYSTEM so you won’t see anything on the workstation. It can’t be used for UVK unless you’re setting it to run a script silently.

I think the main issue here is in Shell execute you get a window that looks exactly like the command prompt(as you should expect) but entering a command in the actual command prompt works just fine but entering the exact same command in shell execute does nothing. It seems that shell execute is really coming up short here.

See that’s what l did. Many different versions of it and it won’t work for me.

It doesn’t even run in the background either. I am trying to run a script I created and nothing happens. If I run it directly, the script works. If I try to run the script through Comodo it won’t work. I have to be doing something wrong here.

Hello @HuskyLogic

Please reply to the support ticket with the script attached so that we can provide a more precise answer.

I’m actually working with @HuskyLogic on this and I have new information.

it actually DOES run the exe but it’s totally hidden even when ran without parameters. When the same command is entered from command line it pops UAC up and asks but when ran from Procedure it only runs the program hidden. He is talking about a script and that is part of the issue but if we can’t get the base program to run, the script to go with it is pointless. So I think it might be easier to focus on that. I will include a picture of the program in the task manager so you can see it. The picture is accomplished using “C:\Program Files\UVK - Ultra Virus Killer\UVK_en.exe”

Hello @Charger440 ,

We have escalated this issue, we will get back to you with an update as soon as possible.

I got an email. But, I think y’all misunderstand. I don’t need it to run with a GUI, matter of fact it’s fine if it does not. From what I can though, after it loads, it’s not doing anything at all. In that image it’s using about 23 meg of RAM but no processor time. It was actually ran with a script that when ran from the command prompt it averages about 50% processor leading me to think that the pictured process is just sitting there doing nothing but hiding. I guess having the option to run it with a GUI might be helpful in some cases but that’s not what I’m after here.

Hello @Charger440,

We will investigate.


We are pleased to inform you that the implementation of the feature that you have requested (Ability to start applications under logged in user (visible interface)) is scheduled to be included in our upcoming release due on Q3 2016.

We appreciate your patience and your understanding in this matter!