SMTP not sending as


I am attempting to configure inbound and outbound email. I have the inbound setup to receive via email forwarding and it appears to be working. But my SMTP is having issues.

I was able to get the SMTP email address added using an email with and using my SMTP provider username/password details. (I am using SendGrid SMTP). If I go to diagnostics and do a test email from the email I added then it goes through without issue and SendGrid shows that the SMTP sending domain is But when a ticket is created or updated it attempts to send an email through my SMTP using SMTP sending domain of @servicedesk instead of so it is then being blocked by SendGrid because @servicedesk does not match to my SendGrid domain Whitelabel.

Is there a simple setting I am missing somewhere that would be causing my notifications to not be sending as the email domain that I have created but still sending through my SMTP?

I have made sure that my default system and alert emails are set to use the newly created email. I have also tried both with and without header spoofing in the SMTP settings. Although I think the SMTP settings are good as the diagnostic test sends without issue.

The other setting I did was set the Default MTA to the newly added email as well.


Hello @RayBTWIT
We created a support ticket in your behalf to address your concern. Please do wait for more information on that ticket.


Did you try to change the defaults from here?…d-Options.html


Hi @Ilker

Yes I did change the defaults to the newly created email. it seems to me that the settings should be right because the email attempts to go out my SMTP because I see it in my SMTP portal attempting to send from an SMTP of @servicedesk domain instead of

The support team has created a ticket for me and have asked for some additional info to help troubleshoot. I will provide the info tomorrow and I will also report back here with any details.


I have the same problem when sending via office 365. The settings are accepted when setting them up. But under diagnostics it fails. Are you using authentication by any chance??

With office 365 you have to use port 587 with authentication which is what is documented by Microsoft.

If you do it any other way it will more than likely not work as they are designed for single domains coming from the sending servers not multiple like there is from C1.

Also there is an Auth issue with SMTP at present with SD, it ignores the setting for no auth and always applies auth.

@dittoit sorry for the late reply, yes I am using authentication, using port 587 as Strobe Tech mentions, but I am not using Office 365 my SMTP is going through SendGrid.

Also Just FYI in case anyone is experiencing the same issue I am. I have been told that this will be fixed with the release this weekend.