Third party patches not working

I’ve been experimenting with the patching options in Comodo One, and have been quite happy with the OS patching functions.
I’ve not been able to get the third party patching working, though. At first, I just tried going into the patch list (Device List->click device name->Patch Management->Third Party Applications), selecting the software I wanted to update, then clicking the Install Patches button.
However, nothing seemed to happen, for multiple computers.

So, I decided I’d RTFM, to see what I was doing wrong, if anything. I found the section about creating an update procedure, and followed it, selecting only a single application (WinSCP) to update to the latest version. I ran this procedure against a computer, and again, nothing seemed to happen. So, I checked the logs for the procedure, and found that it ran, but failed with this error:

Download of failed, reason: Error transferring - server replied: Not Found

I haven’t checked it against other applications, but I’m assuming it’s going to be a similar error for other applications.
Can this be looked into?


Just tried adding VLC Media Player to the software updated by the procedure, and got the exact same error for it. I’m not going to every piece of software, but it seems at least somewhat consistent.

Hello @cbox,

Thank you for letting us know. We will be sending an email regarding this issue as we will be requesting for confidential information to investigate this issue further.

By the way, you can also refer to this list of supported 3rd party applications:

Additionally, here is our in-depth guide on Installing 3rd Party application patches on Windows endpoints.

Thank you.

VLC and WinSCP are both on your supported application list, and I tried the exact procedure in your second link as part of what I was doing prior to actually reading the instructions. By the looks of it, I was doing exactly what I should have been doing, although I also tried to apply a single patch to a single machine through the Device->Patch Management interface, which I haven’t seen in your documentation anywhere, but from the UI, it looks like it should work.

Anyway, I’ll wait for the email.

Hello @cbox,

We have sent an email requesting for the aforementioned data we will need for further investigation. Kindly send a response to that email as some of the information is confidential.

Thank you.