Unable to access service desk -- too many redirections?

Is anyone else having a problem with the service desk? I can access the RMM and the patch management module just fine, but when I go to the service desk module, it fails.

On one computer (computer1/network1/chrome), it complains of too many redirects.
On the same computer (computer1/network1/firefox) it complains of too many redirects.
On a completely different computer and a different network (computer2/network2/firefox), it complains of too many redirects.


Please provide us a screenshot with the error message.



This issue has been escalated and we will get back to you as soon as possible with a status update.

We apologize for any inconveniences this might have caused.


I have this same issue. I have tried using different browsers and Windows OS - windows 7 pro, Windows 8.1 and Windows 10.
This only applies to Service Desk, the RMM module works fine.
I have sent a ticket on this issue but have not had a remedy provided yet.
Anyone have a fix for this issue?

I have a fix for you computerexperts - you can not login as the admin and account admin. Not sure why but after I created a new user and gave him admin rights I was able to login to Service Desk. Just create a new account and then login as that person. Worked for me.:slight_smile:

D’oh! So close… I tried what you suggested, dworley – but no joy. Thanks for the attempt, and I’m glad it worked for you!

The Account Admin account cannot participate in the ticket system as it is meant as an organizational account and not to be used if I had my guess. But creating a new admin account and logging out of that, clear browser (Chrome for me) and it works just fine. Thanks for the tip.

Yeah I’m running into this issue as well, making a new admin account doesn’t seem to sort anything for me, it’s the only module which can’t be accessed.

Have you tried any other browsers, or clearing your cache ?
If this does not work , please give us an email at c1-support@comodo.com and we will check the module for you.

Hello @computerexperts @dworley @SimonJulian and @azon2111 ,

We have managed to resolve the Service Desk login issue for all accounts.
Please try accessing this module now and let us know if it loads as expected.

I am having this issue today, I have cleared the browser cache and so forth and I can now only access Itarian through Firefox only… Please tell me what to do to access through Google Chrome please…

@jessie I’m logging in without any issues, please post a screen grab showing your issue.

I can login via Chrome but as soon as I navigate to the menu and select “RMM” or any other area of the application such as the Service Desk it signs me out and gives me a error notification across the top of the page saying that my Cookies are disabled when in fact they are not! See screen shot attached…

@jessie We have created a support ticket regarding this issue. We will update you shortly

I have started to have the too many redirects issue with one of my computers as well. I have cleared browsing history, cache, flushed dns, rebooted etc.
Any idea’s?

Hello @daniep3,

We have created a support ticket in regards to your report and will reach you via your forum registered email for further correspondence.

I have resolved my issue after hearing back from the support dept. I had to turn off a few flags in Chrome to get it to load the page properly, thanks guys!

Same here, I had to adjust some flags in Chrome. Thanks for your help!