Unable to Connect

Hi All,

I am having issues with one customer in that the RMM tool will not connect. It is available for take over but remote desktop will not let you interact, shell command wont work - the only think that does work is process explorer.

I have RMM on many clients and this is the only site that uses PANDA Endpoint Security - would this be causing the issues? and if so what would i need to exclude from realtime scanning?



Hello msitcmatt,

Can you please tell us when was the first time you encountered this issue? Has it worked before?

Also, would you be able to disable the Panda Endpoint Security from an one of the managed endpoints and retry the tools?

Please provide us the exact version of the RMM agent as shown in Programs and Features.

Hi @dHarvey ,

I’m also having this issue with all devices at one site they all worked find up until the latest update for remote desktop. did anything change in this last release regarding ports? as they are behind a managed Router. i can setup teamviewer as well as uvnc and they work however the RMM remote desktop is not it just hangs at initializing the remote desktop connection. I have attached a screen shot.


The ports used by the Agent are 443, 80 and 8080. Are the rest of the tools working? Or only the remote one?

Hi @Ethan ,

The tools that are not working are Remote Desktop, Shell Execute (this is a problem acoss the board with all sites and devices i have logged another fault for) and System Cleaner. everything else seems to work

Hello Marveltec,

We’ve just sent you an email requesting some additional information regarding this issue.
As soon as we have the logs we will escalate the case to our development team so that they can take a look and apply a fix.

It doesnt seem to be PANDA causing the issue and my issues are exactly the same as @Marveltec

Hello msitcmatt,

We’ve just sent you an email requesting some additional information regarding this issue.
We will add this information to the escalated case as soon as we have them and we will advise further as soon as a fix is in place.

Hi @Matthew ,

I see the Shell Execute is working now and the site i was having trouble using the Remote Desktop feature is also now working. was something resolved? one issue I’m having is that when I deploy policies from the RMM console they show up under “Applied Policy Name” however under policies/devices they show as apply failed but I’ve tested forcing error alerts so the policy is actually applied and working but still showing as apply failed

Hello Marveltec ,

We are not aware about any changes regarding the Shell Execute and the Remote Desktop issue, the case was escalated, the logs will be analyzed and we will let you know as soon as we have any update.

I have also escalated the Policy issue for further investigation.

Yep, we were working on it and had a hot fix for this on Friday. You should hear the feedback from partner support team soon as well. We are sorry for not notify you sooner.