Unable to create/retrieve PLIST after completing 'Create APNs Certificate' process

Hopefully I’m just overlooking something… but I’ve tried to step thru the APNs Certificate creation process from our ITSM portal and do not seem to get the option to save/download/retrieve the PLIST file that I am to take over to the Apple Push Certificates Portal.

Following these instructions: https://help.comodo.com/topic-399-1-788-10259-Adding-Apple-Push-Notification-(APN)-Certificate.html

I have tried to complete the initial Create APNs Certificate step using IE, Edge, Chrome and Firefox on Windows 10 and Windows 8.1… all with the same result. I fill out the required fields and click ‘Create’. I can see the form validating the fields, then after 2-3 seconds the form closes and I am back to the “Create APNs Certificate” button. There are no options to retrieve or download the PLIST/CSR, and I don’t see reference to it in any of the other tabs inside ITSM.

Pop-up blocker and A/V are disabled (just trying to eliminate any apps that might interfere).

Can anyone assist…? I’m not seeing any errors, so I am unclear what exactly to troubleshoot for this to work.

I appreciate any help! We have a series of MacOS and iOS devices to enroll, and I cannot proceed.

Thank you in advance!!


Hello @linkhelp ,

We believe that you are doing the right step through it seems unusual as to why the form would close without any notice or errors. We have created a support ticket for you so that you can be assisted as soon as possible with the process. We will communicate with you via email for this issue.