Bug Reports - Issues for Comodo Service Desk

Hi all,

Lets use this sticky topic to report bugs and issues. When you are reporting it please provide as much as information as you can to be able to pinpoint the problem and quicker resolution.

Here is a general format to report the bug:

A. The bug/issue

  1. What you did:
  2. What actually happened or you actually saw:
  3. What you expected to happen or see:
  4. Whether you can make the problem happen again, and if so exact steps to make it happen:
  5. Any other information (eg your guess regarding the cause, with reasons):

B. Files appended. (Please zip unless screenshots)

  1. Screenshots of UI bugs:
  2. Screenshot of setting page. Can be used instead of typed product and database version.

C. Your set-up - Please provide these when asked specifically as a Private Message to Comodo Staff.

  1. What is your Company Name?
  2. What is your email?
  3. If it is related with Endpoints, Device OS details:
  4. Time Stamp of the problem

I get this error trying to open the service desk.

Fatal error: Uncaught exception ‘Exception’ with message ‘Unable to select the database msp_554a99e4d40fd38973c9e531’ in /home/servicedesk/www/site/pim/pim.abstract.php:44 Stack trace: #0 /home/servicedesk/www/site/scp/staff.inc.php(85): PimOperationsAbstract::switchToMspDb(‘554a99e4d40f d38…’) #1 /home/servicedesk/www/site/scp/tickets.php(17): require(’/home/servicede…’) #2 /home/servicedesk/www/site/scp/index.php(17): require(’/home/servicede…’) #3 {main} thrown in /home/servicedesk/www/site/pim/pim.abstract.php on line 44

I get a similar error.

Fatal error: Uncaught exception ‘Exception’ with message ‘Unable to select the database msp_554abfebd40fd38973c9e557’ in /home/servicedesk/www/site/pim/pim.abstract.php:44 Stack trace: #0 /home/servicedesk/www/site/scp/staff.inc.php(85): PimOperationsAbstract::switchToMspDb(‘554abfebd40fd38…’) #1 /home/servicedesk/www/site/scp/tickets.php(17): require(’/home/servicede…’) #2 /home/servicedesk/www/site/scp/index.php(17): require(’/home/servicede…’) #3 {main} thrown in/home/servicedesk/www/site/pim/pim.abstract.php on line 44


it should be fine now. Could you please try again?

Does it give the same error on all due dates? or specific one?

I tried a few different dates and got the same error.

Please try once more when you set your timezone same with your account from menu -> https://help.comodo.com/topic-289-1-625-7860-c1-service-desk-system-settings.html

If this doesn’t fix it, I will create a ticket for this to be escalated.

In System Settings and Preferences I had set the dates to English UK format Day/Month/Year. By setting it back to US style it works.
Using UK style dates will be required for me to use the Service Desk otherwise it will be confusing to use.

I get the same issue. If I enter the date as d/m/y then I get the invalid date. If I enter it as m/d/y then it works ok. My settings are for d/m/Y as I’m in Australia

I see. We will investigate this and fix the issues.

The date issue when entering a ticket (that I mentioned above) seems to be fixed now. But now once the ticket is created, the due date is listed in the wrong format (ie m/d/y and not d/m/y) on the open ticket.

might that be related with the format chosen for your service desk? It is configurable under settings.


You can only add Companies from the Comodo One portal (the main one). Once the company is added there, you can see see it in the other modules and use it.

The function that you are trying to access cannot be used for the moment.

can’ t access service desk in any way. when trying to access the module on the right appear only “Could not find config file for “asyscom””

Hello @server.asyscom ,

We have emailed you regarding this issue and will let you know about updates on there.


I have stopped receiving email notifications for support tickets (about 2 weeks now) when i go onto the service desk portal and navigate to departments i see nothing however it shows that there are 3 to be displayed. see attached image

Hello @Marveltec

We will escalate the issue and we will get back to you as soon as possible with an update.

We apologize for any inconveniences this issue might have caused.

Hi @Harvey

Thank you issue has been resolved


Glad to hear that all is working fine at the moment!

Hello @Sergey

We were able to create a Project. Please make sure that you do not keep the page opened to much (refresh it before trying to create a project) and can you please try and use another browser?