Devices showing offline

Lots of devices are showing offline when i know they are online as users are using them. What could cause this please?

@monster-it Is the ITSMService running on their PCs?
Have they automatically updated to the latest version of CCC (ITSM) 6.12.8436.17100?…ase-10-21-2017

Hello @monster-it ,

We will create a support ticket for your concern to further investigate the issue.

@nct , Thank you for providing him that information.


@monster-it did you resolve this with support?

See when the last time the devices checked in and issue a “Run Proceedure” -> “Restart ITSM Agent [Script]” As System User.
This should restart the ITSM agent and you will see the devices hopefully showing up.
We had the issue with the Blue vs Green vs offline and a restart of the agent solved most of the machines.

Hello @nct,

We have emailed @monster-it with regard to this case and have asked him if he updated CCC to the latest version as well. We will communicate to our development team if the issue still persists. We are still waiting for his response.

Hello @sferley,

We’re glad that this resolution worked for you. Thank you for sharing this to us.

How can any “Run Procedure” work if the Agent isn’t communicating? The Agent was stuck on “agent trying to communicate” on the bench machine right next to me. I rebooted a few times and it finally showed up on the dashboard… Huh?

I was thinking similar. @comodo.devops and Support how can the script work, to restart the agent, if it isn’t connected?

Hello @nct,

The script will not work if the device is not connected and needs to be checked physically to verify the reason of being offline. A manual restart is recommended with this type of situation. Thank you.

yeah wont work, i’m having to remove the agent alltogether and reinstall each time. then comodo SS wont unistall so have to manually remove and go through the registry. really bad design for a program.

Have you tried the cleanup utility from Comodo to help fully remote their applications?
@monster-it ?

yeah does not work. :*( getting really hacked off with their products now. can access the devices and now having to install teamviewer on all devices.

Suggest you open a ticket with support by sending them the following to start with:

  • dumps of ITSMService.exe and ITSMagent.exe
  • rmmlogs, pmlogs, spmlogs folders (location: C:\Program Files (x86)\COMODO\Comodo ITSM)
  • In additional please check if any dumps are present in Comodo ITSM installation folder.

With all due respect…Could the staff and devs please acknowledge that our customers are already upset and getting the impression that we are inept to do our jobs already because of these issues?

It’s pretty aggravating to them when I call numerous times asking if their computers are actually on. Also…When we are asked to get logs from endpoints, we have to install other remote solutions in order to gain access to them which require someone to be on the other end to give us access. I have long distance clients that I cannot just leave my shop and go on a one or two hour road trip everytime Comodo has an issue.

Something else that frustrated me was…I posted an issue on 9/22, and I didn’t get an email from the dev team till 10/17 wanting logs…

Here here! glad it’s not just me getting (*&$£$ed off with it all. I swapped over from another MSP solution as i was told this was the dog’s knackers

@lscomputersystems @monster-it ,

We have relayed the information to our product developers concerning this reoccurring issue that was supposedly fixed by last 21st release. We will immediately pass all notifications and information coming from our back end team to resolve this case.


It is unfortunate that this issue is still persisting. We have made a follow-up and will reach you with a feedback on your email to get this issue fixed as soon as possible.

Alot of times the agen’t isn’t actually disconnected, just hung. That’s why you need to check the checkin times. A few of mine where hung with having checked in only 2 minutes prior. Thus they are communicating but some channel that the needs isn’t up. It accepted the reset and came up.

@monster-it @lscomputersystems what’s really going to annoy you then is that the beta testers asked C1 support not to push the release on the 21st due to numerous issues just like this one.

​​​​​​​Comodos response was to ignore everyone and push it anyway. Check the preview thread and see what you think.