Error in Comodo Client Security and unable to uninstall

One of my coworkers was informed of and issue a client was having with Comodo Client Security and upon logging in to ITSM he saw this error next to the device

He took steps to uninstall Comodo Client Security first using a procedure from Comodo but the procedure failed. He then tried removing the device with settings to uninstall CCS and then re-add the device to ITSM but this ended in the same error in the portal Error Code 0x80070424. He then tried to manually uninstall it from the windows control panel and this did not work either. He also tried removing it via the windows registry but he was unable and CCS still is reporting being installed on the device with the same error code in the ITSM panel.

Is there anything else we can do. We would like to avoid a reinstall of windows due to the drafting software installed on the device and we do not have direct physical access to the device.


Hi @cru
We created a support ticket to address your concern. Please do reply to the email at your own convenience.

Thank you I will take a look.

Just as a note, this happened to me as well, but just on one or two machines. It seems to have happened when the End-point security update was pushed out.

I’ve held off trying to manually uninstall it though, was going to lodge a ticket for it.

Hi @StevieG ,

Thank you for reporting this case, we’ve already received the support ticket you’ve created and we’ll get back to you as soon as possible through email.

I have had this happen to 4 of my clients’ machines as well.

In case anyone else is wondering, my issue was specifically that the update seemed to have fallen over, with the “COMODO Internet Security” folder being renamed “COMODO Internet Security.old”.

Renaming the folder back to its original name, then restarting the itsm service managed to restore normal communication.

I also have this problem now: on one client I got a warning that the antivirus couldn’t start. Uninstalling via ‘Add/remove programs’ doesn’t work. It start and then ends without actions.
Uninstalling via procedure ‘’ ends in a fault in log:
File “<string>”, line 48 with open(,“wb”) as f: ^ SyntaxError: invalid syntax Manual delete of the Comodo folder in Programm Files doesn’t work also. Reinstall of the agent is not working because the old instance is still found. So: how to force uninstall the antivirus module? Or manual delete? In safe mode is not an option because I’m connected remotely. Thanks

Hi @ailan ,

The reason why you are getting the error is because the client security path was changed.

Please follow the instructions below and applied it on the affected endpoints.

  1. Go to CCS installation folder and rename it to the correct one.
    *remove old suffix
  2. Reboot the pc

After the reboot of your endpoint, you will able to update the client security from the portal to the latest version. This behavior was fixed in the current version so we expect that you will not get this kind of error message again.

I too have had significant issues with CCS (as per my forum post).

I tried the rename folder and reboot method - failed
I tried to apply the update from within Comodo - failed
I tried to uninstall through Programs and Features - failed
I tried to uninstall using Comodo’s scripts - failed

I have now gone as far as removing all Comodo components manually from Program Files, ProgramData and Registry, and still cannot re-install. I have had to install Avast on one of my users until i can get hold of their machine physically to re-image it, just to get them a basic level of protection…

I’m one step further:
uninstalling the program via Windows or manually, doesn’t work.
You can unregister the program by Windows Installer with the ‘Windows install Clean Up’ tool. (…p_utility.html )
Then you can reinstall CCS again.
Only: after installing the client like normal, I have to select what to activate:

Now I don’t know the serverdetails…
But maybe it helps you also to get one step further.


Hi @ailan
Thank you for the tip. Here is another (official MS) link of the Microsoft fixit for problems that block programs from being installed on to/removed from the system.

The ITSM server name will be different for each MSP. This only gets asked if you used the stand-alone installers for CCS. But if initiated from the ITSM portal, the installation will proceed like any silent installation unless you change it to behave differently (again, on the ITSM portal).

Thanks Rick C. I tried to install it via the portal but that fails everytime.
I retried it now again: uninstalling CCS from Windows Install didn’t work. Then I used your link and uninstalled CCS (again) with the fix.
After that and a restart, I initiated the install from the portal but still, the install fails.

Eventvwr: Product: COMODO Client - Security – Installation failed.

Is there some procedure to force install the CSS manually (from prompt)?

Did you happen to get an error 1603 with the installation, @ailan ?

Do try the suggested actions in the following link: error 1603 suggested solutions

Hi Rick C,
Yes, in the eventviewer I get a 1603 error.

The link you sent states:

You may receive this error message if any one of the following conditions is true:
Windows Installer is attempting to install an app that is already installed on your PC.
The folder that you are trying to install the Windows Installer package to is encrypted.
The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive.
The SYSTEM account does not have Full Control permissions on the folder that you are trying to install the Windows Installer package to. You notice the error message because the Windows Installer service uses the SYSTEM account to install software.

The 1st reason is likely true because I can’t uninstall the old CSS instance (normally).

Hi @ailan

This may help:

Once done, please try to install the latest version of Comodo Client Security again.

Kindly let us know if it worked for you or if you need further assistance.


Hi Emily,
Thanks for the info.
I already tried that; it was the link that Rick C posted 3 posts ago.
It didn’t work. I could uninstall CCS via the tool and it stated that errors were fixed. But the installs from the portal and offline installer are failing.

Hi @ailan ,

We will further investigate this issue and we’ll get back to you as soon as possible through email.

Any update, ?? i have the same problem on 1 server?

Hi @dittoit
Unfortunately, we don’t have any update yet on @ailan 's situation as he has yet to reply with the results from his side.